Recipe Schema Not Working Properly

#64253
  • Hello!

    I run a recipe site and since Google emailed me to change all posts to the recipe schema I tried to do that with Rank Math. However, when I put the text into the Instruction Type field (any of them, for that matter) and update the post, the page displays a single chunk of text, instead of consecutive steps.

    When I right-click and go to Inspect Element on the post page, I see quotation marks at the beginning and end of the instructions. Shouldn’t there be <p> at the beginning and </p> at the end of each paragraph?

    You can see an example of this here.

    Can you please help me fix this issue. I want to continue using RankMath; I like it and got used to it. But I really need to get this done as soon as possible.

    Looking forward to hearing from you guys!

    Cosmin.

Viewing 31 replies (of 31 total)
  • Hello,

    Thank you for the feedback.

    We’re glad everything is working out fine so far.

    If you have any further question(s), please let us know. Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 31 replies (of 31 total)

The ticket ‘Recipe Schema Not Working Properly’ is closed to new replies.