WooCommerce Removing bases don’t work

  • We are trying to achieve /used-golf-balls/titleist/titleist-pro-v1/

    We have removed base and we have removed category base using Rank Math WooCommerce settings tab. /used-golf-balls/titleist/
    these brand pages go to a 404 on and off when not logged in to the website. Please help!

Viewing 15 replies - 16 through 30 (of 30 total)
  • Hello,

    I was thinking something after reading this:

    It appears that for some reason access the page as a logged-in user make it work for users not logged in.

    That sometimes happens in cache systems. Usually, the logged user is never cached, so you see instantly any changes in the site. And not logged users (in this case Incognito) see the cached version.

    I see you are using for example Cloudflare. Could you check if it could be a caching issue? (With Cloudflare or with a plugin)

    Looking forward to help you.

    Hi,

    Any luck figuring out what’s going on with this issue?

    Thanks

    Hello,

    Were you able to check what I suggested in my last post?

    I see you are using for example Cloudflare. Could you check if it could be a caching issue? (With Cloudflare or with a plugin)

    If yes and it still doesn’t work, let us know.

    Looking forward to help you.

    Hi Alberto,

    This actually my staging site, so no cloudflare and I have cleared cache multiples on the caching plugin I used. I did disable this in my live site since I couldn’t have the 404s there. I refreshed staging from live just before reverting back the category base setting.

    Hello,

    Thank you for contacting Rank Math today.

    I accessed your staging site and resaved your redirection settings under Rank math > General settings> Redirections and somehow I can’t face the issue from my end anymore. I have accessed with different browsers, cleared browser data and even in incognito. Please check if you are still facing the issue from your end.
    P.S. I have been testing this link: https://twoguyswithballs.staging.wpmudev.host/used-golf-balls/honma/

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi,

    So I copied my live again to staging in order to test this out. It appears that saving redirect setting (or anything in general settings) only works temporarily. After awhile, I start getting the 404’s again. Appreciate if you could take another look.

    Right now the category base removal is turned off in staging, however, feel free to turn it on and test.

    Thanks

    Hello,

    Thank you for contacting Rank Math today.

    The issue doesn’t seem to be happening on my end anymore. I accessed your site and confirmed you have the latest plugin update and the strip category base was turned on. Without changing anything, I tested the link you had provided with 404 in incognito with different browsers, and as you can see in the attached screncast, the issue is no more.

    Please share a screencast if the issue is still happening on your end.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi Michael,

    See screen recording below. The problem was when I copied live to staging I forgot to disable the redirects, so whenever you clicked on a subcategory you were taken to the live site (where I don’t have the category base removal) and it appears to be working.

    So looks like the issue still exists for users that are not logged in.

    https://streamable.com/j1ev32

    Thanks

    Hello,

    After a lot of testing, it seems it has something to be with your plugin “Hummingbird Pro”.

    I have recorded a new screencast (it is the last link in the Sensitive Data section) where I show all the testing:

    – With Hummingbird enabled, it loads fine when the user is logged in.
    – With Hummingbird enabled, it doesn’t load fine for non logged users.
    – With Hummingbird disabled, it loads fine for all the users.

    Could you check it?

    Looking forward to help you.

    Thanks will check on it. Can you let me know how the remote product category base works behind the scenes so I can check with WPMDUDEV support? This will help them narrow down what feature in hummingbird is causing the issue.

    Hello,

    Thank you for contacting Rank Math today.

    Allow me to consult the dev team on this ad get back to you.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi,

    I am checking again today and looks like the categories no longer work even with Hummingbird disabled. I did not change any settings from yesterday.

    https://twoguyswithballs.staging.wpmudev.host/used-golf-balls/

    Appreciate if you could review this again. It does look like you need to give some time after the initial changes to start working. It also appears that the act of saving something triggers this to work for awhile. For example, the above main category was not working. I went into permarlinks, deleted the category and tag base and saved, and now it’s working. I assuming if I check in a couple of hours this will stop working again. So in general it appears that the conflict is not related to a specific plugin or setting, but something happening overall.

    As an additional test I enabled hummingbird again and the category pages still work in chrome incognito mode.

    This is a tough one, thanks for the continued support.

    Hello,

    The URL is working fine.

    If it doesn’t work sometimes and requires you to save permalinks, that means you have some inherent issues with flushing rewrite rules. It works for more users without having to flush rewrite rules.

    https://developer.wordpress.org/reference/functions/flush_rewrite_rules/

    Please share the links with the web host so they can check.

    Thanks, I will pass that info to my hosting support.

    Just to clarify. It’s not it starts working when I save permalinks. Saving anything appears to get it to start to work. For example, if I am getting the 404’s and I go to rankmath general settings and save, then it also starts to work. Just want to you make sure that your comment regarding rewrite rules still hold true.

    Can you please provide some insight on how the category base is removed behind the scenes? I can then pass this on to WPMUDEV who is my hosting provider as well the developer of several plugins I use such as Defender and Hummingbird. I believe this will help them identify if anything in there plugins is causing a conflict.

    Thanks

    Hi,

    When you make changes in the general tab, Rank Math also flushes the rewrite rules to give you a consistent experience.

    We use wp hook to trigger the redirection – whether it is stripping the category base or adding redirects via WordPress Dashboard > Rank Math > Redirections. We store redirects in a custom table and we do not make any changes to your .htaccess file to make the redirects work.

    I hope that is sufficient information for your web hosting provider to check this issue.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 16 through 30 (of 30 total)

The ticket ‘WooCommerce Removing bases don’t work’ is closed to new replies.