WooCommerce Removing bases don’t work

  • We are trying to achieve /used-golf-balls/titleist/titleist-pro-v1/

    We have removed base and we have removed category base using Rank Math WooCommerce settings tab. /used-golf-balls/titleist/
    these brand pages go to a 404 on and off when not logged in to the website. Please help!

Viewing 15 replies - 1 through 15 (of 30 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Additional info – my webhost is WPMUDEV and it’s an Nginx server.

    I did see another thread where it suggested the htaccess file my be getting reset (nginx.conf) in my case. I contacted my web host and they had the following response.

    Can you share the Nginx rules provided by Rank math plugin
    Our hosting team can apply them in nginx.conf file

    Since I was having the issue in my live site, I have turned off the Remove category base option. However, I did copy live to staging so you can help figure out why the 404 error keeps happening. I have update the sensitive data section with login info to my staging site.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Alberto,

    Thanks for the continued support on this. In the other thread you had mention to include the following in Nginx.conf.

    # START Nginx Rewrites for Rank Math Sitemaps
    rewrite ^/sitemap_index.xml$ /index.php?sitemap=1 last;
    rewrite ^/([^/]+?)-sitemap([0-9]+)?.xml$ /index.php?sitemap=$1&sitemap_n=$2 last;
    # END Nginx Rewrites for Rank Math Sitemaps

    Just to clarify where things are at.
    1. I have disabled the strip category base in live until this is resolved.
    2. I have copied live to staging and provided access so you check the issue.

    Are you able to check my staging OR are you suggesting that I enable the strip category base again in my live site and check if adding the above rewrites help?

    As an additional note, I have the strip remove (shop) base turned on for products and at appears to be working fine. i.e. no 404’s for product pages.

    Thanks

    Hello,

    Both the URLs in your OP are working fine.

    I am not seeing any 404s. I checked and Rank Math is enabled as well.

    Where exactly can I see the issue?

    Is there a set of steps we need to follow?

    Did you check live or staging?

    I had disable the hide category base option in live because of the 404.

    So, here’s what I’ve noticed in live.
    No problem when browsing when logged in.
    404 are intermittent. It works sometimes, and other times I continue to get 404s on one device/OS/browser, and I do not get 404s on another browser/device

    As an example see the brand below.
    https://twoguyswithballs.staging.wpmudev.host/used-golf-balls/honma/

    When I access the above URL in chrome incognito mode I get a 404. When I access the same URL while logged in as an admin I do not get the 404. See example screenshots below. Note the URL is the same, but one is chrome incognito and the other is logged in to wpadmin.

    https://ibb.co/qNgtzF3

    https://ibb.co/f4PLKx3

    Hi Todd,

    Quick check to see if you had a chance to look into this in my staging site? Let me know if you have any trouble with logins. Please note the front end is also password protected and I have shared the credentials in the sensitive data section.

    Thanks for the support on this so far.

    Hello,

    Thank you for contacting Rank Math today.

    I have had a chance to look into the issue with Page not found. It seems to be related to your Defender Pro Plugin.With the plugin disabled, I logged into the front end with no 404. I then cleared the browser cache and reopened the browser and tried it with the plugin active and the 404 error appeared.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Thanks for getting back with info.

    I did notice the behavior with the defender de-activated, I didn’t get a 404s. When I then activated defender again I still didn’t get any 404’s. Are you able to help narrow this down further? I will also contact WPMUDEV support who is the developer of the plugin as well as my hosting provider.

    Part of the problem is this is sometimes hard to replicat. As in right now the category pages that were not working before in my staging is working with defender active. I do agree there appears to be a link with the Defender plugin. I have disabled 404 detection/lockout in the plugin.

    Appreciate if you are able to dig a bit deeper and provide me with any more that I pass on to WPMUDEV support.

    Hi Michael,

    I had a troubleshooting session with WPMUDEV and here’s some strange behavior we noted was as followings. This was with Defender active but everything under Defender Pro > Advanced Tools > Security Headers turned off.

    1. Open brand page in Chrome incognito. 404 appears. For example https://twoguyswithballs.staging.wpmudev.host/used-golf-balls/topflite/
    2. Access the same URL from a logged in browser and category page shows up correctly. In general we know that there’s no 404 errros when logged in.
    3. Next go back to the incognito window and the page works fine.

    It appears that for some reason access the page as a logged in user make it work for users not logged in. Any idea on what can cause this behavior.

    Could you also provide some info on the how the woo product category base is stripped behind the scenes? I can forward this to WPMUDEV support in case it helps them figure out what’s going on.

    Thanks for the support on this so far.

    Hello,

    Thank you for contacting Rank Math today.

    At first I thought it was something to do with IP address, but I tried with a different device and it didn’t seem so. It seems once a user is granted access, they maintain it with no 404s, but if not the see a 404 page. Allow me to consult on this.

    In the mean time, do not hesitate to let us know if you need our assistance with anything else.

    Hi again…

    Just as an additional note, I’ve disabled the base (i.e. shop/) for products and that seems to be working fine. It is only the category base removal that causes 404’s/

    Thanks

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 30 total)

The ticket ‘WooCommerce Removing bases don’t work’ is closed to new replies.