Sitemap Couldnt fetch issue

  • Hello

    We are facing the issue from the December 2018 for our site and getting an error of “couldn’t fetch” in sitemap report. Our Pages are deindexed acc. to coverage report and we lost our rankings in the result of that…

    I’m getting this when doing “live Test’ in the console for sitemap-

    Discovery: Not checked in live tests

    CrawlTime – May 18, 2019, 5:16:27 PM
    Crawled as: Googlebot smartphone
    Crawl allowed? Yes
    Page fetch: Successful

    Indexing
    Indexing allowed? No: ‘noindex’ detected in ‘X-Robots-Tag’ http header
    User-declared canonical: N/A
    Google-selected canonical: Only determined after indexing

    But I’m Unable to “View Tested Page” in the console; it remains unclickable and shows page was not fetched.

    from december our sitemap crawls in April, 2-3 days continually and then again show error from 14 April. and last read time, or anything else nothing changed in report. there is only error…

    Tried many plugins, verify hosting, site, configurations, removed sitemap, resubmit sitemap but nothing happen.
    We are on Kinsta and they said: As you saw in the HTTP header for post-sitemap.xml, it’s returning HTTP200 without any headers that would cause errors.
    and said tocontact with you..
    kindly figure out the issue and solve the issue…
    Waiting for your response…
    Thanks

Viewing 15 replies - 1 through 15 (of 28 total)
  • Hello,

    As you said, it is happening with multiple sitemap plugins so the issue must be from your website’s end.

    Have you tried testing from another server maybe?

    as Kinsta is a reputable name i cross checked them many times so i dont change hosting to test…
    Do found any issue with web hosting?

    Hi there,

    Thanks for the follow up.

    No we have not come across any issues with your host. Please get in touch with them and check whether there are some errors that are reported on your server logs that could give you a hint on why this is happening.

    I hope this info helps. Thank you.

    Hello

    As I told above there is no issue on our host, I have verified this many times from kinsta…

    and as you said above that it could be an issue with our site then you can verify that too because you are theme developer…

    looking for your help and solution

    if you want then i can give you access to kinsta acc. you can verify from them…..

    Hi there,

    Thanks for the follow up.

    We would be happy to check this issue for you.
    Please share a new password and some FTP access since the one your shared earlier does not appear to be correct.

    I am looking forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello

    That was site login details

    No i added sftp login details… kindly ckeck now.

    Hi,

    We may need access of your GSC as well to verify if the changes we make are working.

    If that is not possible, please follow these steps.

    1. Head over to Settings > Permalinks.

    2. Hit the save button once.

    3. Clear your website cache and exclude sitemap file from being cached. You can ask for help from your host if needed.

    4. Go to GSC and remove and all sitemaps you have there.

    5. Submit it again with domain.com/sitemap_index.xml

    6. Wait 48 hours and see if it is fixed.

    Do let us know how it goes.

    Hello

    I can give you access kindly share your gmail i can give you access…
    on that mail…

    Hi there,

    Thanks for follow up.

    I have added my email on the sensitive data section.

    I am looking forward to your response.

    Kindly check

    Hi there,

    The wp-admin logins are still not correct, I am having trouble logging in to the backend. Please share a new password for the user you created for us.

    Thank you.

    Kindly check now… with same password

    Hi there,

    Thanks for the patience.

    I have made some changes to your sitemap settings and robots.txt file.
    Please let us know if the issue persists after 48 hours.

    Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 28 total)

The ticket ‘Sitemap Couldnt fetch issue’ is closed to new replies.