Rich Snippets only show up in Products then i resave them

  • hi

    I did rebuild a site for a client based on old theme with wpbakery and WooCommerce 3.XX
    Now everything is online and running with Elementor and Jet WooCommerce. I did instally Rank Math
    and uninstalled Yoast SEO plugins. The import seems to work.. But not then it comes to the
    Product pages. My single Products don’t show in google as Products in the Google structured testing tool.
    Only then i go in side the Item under Rank Math Schema Builder and do Save for this post.
    So basicly i need to resave this. The problem is i have 2000 + Prodcuts.
    Is their a way to do this in a batch commmand ? Because that the only fix i found for this problem.

Viewing 15 replies - 16 through 30 (of 34 total)
  • Yes i am using WProcket… and ofc i did clearly all the caches

    i upgraded to the latest version now. Maybe a Dev can see what is wrong.

    example URL: https://letz-go-shop.de/produkt/e-zigaretten/komplettset/smok-guardian-e-zigaretten-set/

    Btw, disabling WP Rocket and its caching or minification didnt help solve the problem.

    Tested 1.0.52.1 out & still just outputs WebPage schema type. Tried duplicating an existing product but still the same.

    I suspect it is because Rank Math now has a ‘WooCommerce Product’ schema type separate from the generic ‘Product’ schema type (that can be manually generated through the Schema Builder) and somewhere in the code its pointing to the wrong one.

    The new WooCommerce Product shema type just showed up in the latest version. It might be the problem but i already had this error when there was just the product shema available.

    I noticed today while using the keyword analytics in my pro version, that the shema type isnt recognized. Screenshot here:

    https://imgur.com/jVlyIhQ

    Rank math ? its now 2 weeks guy .. can you pls fix this problem for us… 🙁

    Yeah it would be great to get a fix. Otherwise i have to downgrade again and cant use my pro version.

    Christian
    what can we do now ? 🙁

    the only thing is downgrading atm.

    Downgraded to 1.0.49 again. After deleting my Cache everything is detected as it should be. I could even remove the “brand” code snippet as the option under rank math-woocommerce to select an attribute as brand works now.

    Hello,

    We are extremely sorry about this but we have asked our dev. team to take a further look.

    We will get back to ASAP.

    Hello,

    If you have taken a complete backup of your website, can we upload the files that have the fix in it?

    Looking forward to helping you. Thank you.

    Hello ,

    yes we do backups every night … but do to the fact we have sells everyday.. i would like to agree on a time so i can save it right before you make the changes..
    you also can do that by using the updaraft plugin… that is installed… so if you make a update before the change… this should be fine i guess.

    Hi guys so whats the status now ?

Viewing 15 replies - 16 through 30 (of 34 total)

The ticket ‘Rich Snippets only show up in Products then i resave them’ is closed to new replies.