Post Is not showing in Sitemap?

  • During Setup Wizard I have a select page And post both for the sitemap but in my search console in sitemaps reads the Only page is showing You can see the screenshot? And for the post separate link is generated by the Rank math plugin.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Hello,

    Thank you for contacting Rank Math today.

    I have checked your sitemap file(yoursite.in/sitemap_index.xml) and it seems to only have the page sitemap. Could you please head to Rank math > Sitemap settings> Posts and make sure you have enabled the posts sitemap. If enabled, please check if you have any posts and that they are not set to noindex.

    If you have checked all above settings and the issue still persists, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    I am using wordfence plugin in during the scan, I found some malware you can see in the screenshot. But now I have deleted the malware. This malware is related to the sitemap.

    Hello,

    Just to be sure, did it fixed your issue or do you still need help? If you need help, we will continue here helping you.

    Looking forward to help you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    No, I am still facing the same problem, the sensitive data section is updated you can look close to settings, thank you.

    Hello,

    I cleared your site cache, disabled then enabled the sitemap module in Rank math dashboard and now the sitemap seems to appear just fine. Please check the screencast I have added in the sensitive section.

    Hope that helps. If you have any further question(s), please let us know. Thank you.

    I am unable to see you have screenshot added.

    Hello,

    I have added a new screencast with http://www.loom.com in the sensitive section please check

    Looking forward to helping you. Thank you.

    ​​​​​​

    Yes, it’s showing in the Sitemap Index file, but there is still a problem it’s not showing in my search console.

    Hello,

    Could you please remove all your sitemaps and resubmit only your main sitemap on your GSC. Give it sometime for your sitemap to be completely crawled and let us know how this goes.

    Looking forward to helping you. Thank you.

    ​​​​​​

    I have submitted the sitemap again. Let’s wait.

    No, it’s not working, I wanna show you the screenshot, it’s creating the problem or not let me know, and tell me how I can fix it.

    Hello,

    The screenshot is of your robots.txt. It seems to be conflicting because it is sowing a different sitemap URL which is not your site’s sitemap URL.

    Could you please remove the robots.txt in your root folder to allow Rank math to automatically generate the virtual file.

    Looking forward to helping you. Thank you.

    ​​​​​​

    I had updated the robort.txt file and wait for days still not seeing the post sitemap in
    “Sitemaps read” area in search console, I had also deleted the sitemap and re-submit the sitemap. But still, problem remains.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 24 total)

The ticket ‘Post Is not showing in Sitemap?’ is closed to new replies.