Parsing error: Missing ‘}’ or object member name

#191143
  • My initial motivation for installing rank math is I was hoping it might be able to help with this alert I’ve received from google search console

    Parsing error: Missing ‘}’ or object member name

    Can your plugin help with that or can you give me any advice ?

    Thanks

    Andrew

Viewing 15 replies - 1 through 15 (of 26 total)
  • Hello,

    Thank you for contacting Rank Math and bringing your concern to our attention. I’m sorry for any inconvenience this issue may have caused you.

    To further check this issue, please also provide the affected URL in the sensitive data section.
    Sensitive Data Section

    It is completely secure, and only our support staff has access to that section.

    Looking forward to helping you.

    Thank you.

    I’m not sure if I understand the question. The problem is to do with pages throughout my website https://www.yachtsandproperty.com/ Do you want me to give you access to my google search console as that shows a sample of the effected pages ?

    Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress & FTP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Thanks. Here you go [Moved to Sensitive data section]

    Hello,

    Thank you for that information.

    I’ve checked your site using our Health Check plugin, and it seems that your theme Javo Directory is causing that issue on your schema.

    By following the steps in our guide with your current theme only activated (troubleshooting mode), the issue still persists upon checking in Google’s Rich Results test tool.

    In this case, you may need to get in touch with your theme provider to fix or disable the schema being outputted on your site.

    I hope that helps. Thank you, and please don’t hesitate to contact us anytime if you need further assistance with anything else.

    Thanks Reinelle

    The theme author is no longer providing support. Do I need the theme outputting schema ?

    I don’t really know anything about schema or what schema my theme outputs but I use Yoast as well as your plugin, do they give me everything I need and if so can you help me or tell me how I disable it on the theme ?

    Thanks again

    Andrew

    Hello,

    Thank you for the follow-up, and apologies for the delay.

    We always recommend using only 1 SEO plugin to handle your website’s schema to avoid conflicts as well as confusion to search engines.

    Unfortunately, this schema being generated by your theme cannot be disabled using Rank Math or any SEO plugins.

    Since that schema is faulty, it needs to be disabled as that is causing an error to your schema. If your theme provider is no longer providing support, we can try disabling that schema being generated by your theme. To check further, please also add your FTP logins in the sensitive data section.

    Looking forward to helping you.

    Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    It seems an automated message may have been added above but just to be sure, thanks for your help and I’ve added the FTP details in the sensitive data section as requested. Kind regards, Andrew

    Hello,

    Thanks for getting back to us.

    I commented out the line from your theme that was outputting the schema on your website and now the validation is passing and that error is no longer being displayed.

    Just for future reference, the line I commented out was in your main theme’s functions.php file and it was reading like this: require_once JAVO_HDR_DIR."/schema-markup.php";

    Hope this helps solve your issue.

    Don’t hesitate to get in touch if you require any further assistance.

    Fantastic, thank you
    The parsing errors are srtill showing in Google Search Console will they take a while to go ?

    Hello,

    Thanks for getting back to us.

    The change was just made so Google didn’t have time yet to crawl your page. However, at the top of the error page, you should see a button that allows you to validate the fix or something similar.

    If you press that button that will tell Google that the issue is fixed and it should re-crawl those pages as soon as possible.

    Hope this helps clarify any doubts.

    Don’t hesitate to get in touch if you have any other questions.

    I did try that actually, it said it could take up to a minute but nothing happened however, if I look at it now it say “Validation started
    Started: 03/05/2021”, so I guess it must be crawling. How long should I give this Miguel ?

    and how do I know when its complete, so I can check if it was successful ? Thanks, AH

    Hello,

    This now depends on the speed of Googlebot when crawling your website. I would say to give it a couple of days and see if those errors are no longer displayed on your Google Search Console.

    Unfortunately, there’s nothing we can do to speed up the Googlebot, it’s just a matter of waiting for it to finish now.

    If you have any other questions don’t hesitate to get in touch.

Viewing 15 replies - 1 through 15 (of 26 total)

You must be logged in to reply to this ticket.