Not able to select property of Analytics after update

  • Hello,
    Please check the screen shot. I am not able to select property of my google analytics account after the update. Before update it was working fine.

    ScreenShot

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hello,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    Please replace the current version with this one:
    https://i.rankmath.com/aGxNMQ

    and then connect again. Please let us know if the account gets disconnected again.

    Looking forward to helping you.

    i HAVE ALREADY DOWNLOADED THIS AND STILL THE SAME PROBLEM

    Hello,

    If that doesn’t help, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress & FTP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you. Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    We released a new update(v1.0.50) you can try to see if that helps.

    Please clear the caches, server, and WordPress after updating.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Version : 1.0.50.1

    Still .. Properties not showing :

    null

    Now properties are showing, but rankmath keeps getting disconnected everyday. When I login everyday in the morning I have to reconnect it again.

    Reply to Amr subzero – Properties won’t show if your data stream in the analytics account is apps and web. You have to create a property with only web selected.

    @Aalok Deshmukh

    I’m using GA4 Property which i have no clue whether it’s only web or both (web and apps).
    because it’s not giving me the option to set web or web & apps when creating new GA4 properties.

    but i’m sure i’m only using only Web Data Stream for that property. and it’s still not showing.

    GA4 Property

    I’ve tried to see if i can create a property for (Web) only. but it seems new GA4 properties can be set to web or apps from Data Streams tab. which is set correctly in my case.

    Can you give more info about that?

    Hello,

    The Analytics module in Rank Math does not work with v4 of Google Analytics.

    We will be working on that very soon.

    We will keep you posted about the progress.

    Man, that’s frustrating. Could you pull that out of the setting till you get it fixed? Wasted 45 mins of my day. Thanks

    Everytime I log out of the wordpress site and then log back in the google services gets disconnected.

    Hi, please when is the plugin going to be compatible with v4 of Google Analytics?

    I got sort of the same problem. Could not select a property. And there was a hiccup when the setup wizard was going to validate the account at Rank Math. I had to return to the WP admin and start the Setup Wizard again. Then it worked. But when starting to fill out the Rank Math settings, I could not select a property. I reverted to a backup of the site where I still used Yoast. Will try again in a week.

    Hello,

    Our team is working on making Rank math compatible with v4 of Google Analytics. Please bear with us in the moment.

    We will be sure to let everyone know when this is done and added to the plugin release.

    Looking forward to helping you. Thank you.

    ​​​​​​

Viewing 15 replies - 1 through 15 (of 21 total)

You must be logged in to reply to this ticket.