I cannot click.

#407100
Viewing 15 replies - 1 through 15 (of 21 total)
  • Hello,

    Thank you for contacting Rank Math support, and sorry for any inconvenience that might have been caused due to that.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress & FTP logins in the designated Sensitive Data section.

    Please do take a complete backup of your website before sharing the information with us.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Thank you for providing a login for us to investigate the issue.

    Unfortunately, it seems that the troubleshooting mode on your website doesn’t work properly on our end. I tried enabling Rank Math plugin while in troubleshooting mode but it won’t activate. I already tried doing this in chrome or firefox and it doesn’t do much.

    At the moment we can’t further troubleshoot the issue as clicking the button also doesn’t generate a script error on the browser console.

    Is it possible for you to create a staging website for us to deeply debug the issue without worrying about breaking your live site? If so, please create one, replicate the issue there and share the admin login here so we can further determine what’s causing this issue.

    Looking forward to helping you on this one. Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Rank Math by default removes the ?replytocom from the Comment reply link since most of the sites show the reply form right after the comment. On your site, although the page reloads and shows the form. To fix it, I have added the following filter code to your theme’s functions.php file:

    add_filter( 'rank_math/frontend/remove_reply_to_com', '__return_false');

    The link is now working on your site. Can you please confirm?

    I hope that helps.

    It doesn’t always work. Sometimes yes, sometimes no.

    Hello,

    Everything seems to be working fine on your staging site. Can you please clear the cache and check again? If it still doesn’t work after clearing the cache, then please share the link of the post.

    Looking forward to helping you.

    That’s why it didn’t work. You meant on the staging page. It works, but it’s slow.

    Hello,

    Can you please give us more details of what is not working on your site?

    On the staging site, clicking the Reply button reloads the page and shows the Form with textarea. Although I noticed when we go back to the page again and click the button then it takes a few seconds to reload the page. But this happens even when the Rank Math plugin is not active. So there is probably some other plugin code or your theme that is causing this issue. Please check the screencast I added in the Sensitive Data Section.

    Please let us know if we are missing anything here.

    Looking forward to helping you.

    I will check again when I have resolved the issues with Cloudflare.

    Hello,

    Sure, let us know how it goes.

    Meanwhile, if you have any other questions, please feel free to ask.

    We are here to help you.

    I confirm, there are performance issues on the button after the click.

    What to test;
    – Click on reply makes it wait a few seconds.
    – Subsequent clicks are quick.
    – Go to the home page.
    – Blog.
    – Press the article concerned (at the moment it is the first at the top).
    – Click on the reply button. You will notice that the loading has returned as slow as in step one.

    Hello,

    I tried following the steps you mentioned and I can’t seem to replicate it from my end. Please refer to my screencast in the Sensitive Data section.

    If it still seems I am missing something, sharing a screencast from your end would save us all the time in trying to replicate the issue.

    We are looking forward to helping you with this one. Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Could you please confirm if the issue is when the “Reply” button is clicked the first time the page reloads?

    I went ahead and disabled Rank Math and the same is happening from my end as you can see in my latest video screencast in the Sensitive Data section.

    Looking forward to helping you.

Viewing 15 replies - 1 through 15 (of 21 total)

You must be logged in to reply to this ticket.