Elementor 404 template breaks 404 monitor

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,

    Thanks a lot for your query and we are so sorry about the trouble this must have caused.

    When did this start coming back? If you switch to any other theme, does the 404 monitor start recording again?

    Hi Todd,

    Sorry for my late reply. I didn’t receive any follow-up notification email neither in the inbox nor the spam box.

    I modify the Elementor 404 template after stopping seeing 404 monitor record. Your team spot the issue last time by importing my template. I upload it via google drive here. Hope it helps this time too. Thank you for the awesome work your team did.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Robert,

    I just heard back from the dev. team. We had fixed this issue but we had to revert our “fix”.

    There is no way to fix the Elementor 404 reporting issue without having it reported 3 .map URLs whenever Editor is loaded.

    The is_admin condition doesn’t work in the Elementor editor because it loads the content as front-page in an iframe.

    The problem is, this hook runs in editor as well so the error is logged for the missing .map files.

    Could you please get in touch with the Elementor team and see if they can add some condition in their plugin so the is_admin() condition will return true?

    Did you try using any other 404 monitoring plugin? Did it work for you?

    Hi Todd,

    Thank you.

    • Can you help direct me where to post the issue to get help from Elementor? What content to post? I am not a programmer. 🙁
    • Why other 404 or SEO plugin can track 404 errors with Elementor 404 page?

    Thank you.

    Hello,

    Thank you for contacting Rank Math today.

    I can suggest that you talk to support at https://elementor.com/support/ and then share a link to this thread.

    Let them know that we would be happy to work with their team to fix this.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Got it. And just send it to Elementor team,. Hope it can be solved soon. Thank. you.

    Hi Robert,

    We hope so too.

    If anything is needed from our end, we are always here to help.

    Thank you.

    Hi there,

    I will follow this thread as I probably have the same issue. I did not realize the Elementor 404 template broke the 404 monitor but since I have a 404 template this must be it.


    @todd
    : you asked whether other 404 monitors work. I also have Shield Security installed and this one picks 404’s up under ‘audit trail’ and under ‘traffic’.

    Cheers

    Hi Pieter,

    Thanks for the chiming in and sharing the additional info.

    We will keep you posted on any updates from our end.

    Pieter,

    There is no way to fix the Elementor 404 reporting issue without having it reported 3 .map URLs whenever Editor is loaded.

    The is_admin condition doesn’t work in the Elementor editor because it loads the content as front-page in iframe.

    There are only 2 hooks defined in the canvas template. We are using before_content hook: https://github.com/elementor/elementor/blob/master/modules/page-templates/templates/canvas.php#L34

    The problem is, this hook runs in editor as well so the error is logged for the missing .map files

    If you need help with anything else, please open a new support ticket here so we can help:

    https://support.rankmath.com

    We are always here for assistance.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 11 replies - 1 through 11 (of 11 total)

The ticket ‘Elementor 404 template breaks 404 monitor’ is closed to new replies.