API Error

  • Hello, I am having a similar issue to a few other people I’ve seen post here. In the SEO Analysis tool, it stops after hitting about 40% in “Start Sitewide Analysis” and displays an error: “API Error: Invalid URL. Please try again with a valid URL.” It also only shows 12 total tests, which seems to be low after looking at other people’s notes.

    I’ve tried flushing the SEO Analysis data in the Tools area but no change. I’ve also tried running the SEO Analysis about a dozen times as I saw that helped a previous ticket poster, but same results.

    • This topic was modified 7 months, 2 weeks ago by Lauren Morley.
Viewing 15 replies - 1 through 15 (of 23 total)
  • Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Thank you for contacting Rank Math today.

    It looks like there is are some server configuration settings that are blocking the API call on your site. Could you please get in touch with your host and check if there are some firewalls that could be blocking the outgoing connection?

    I have also gone ahead and tested your site on our online analyser and the same error is reported.
    https://rankmath.com/tools/seo-analyzer/

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello Michael & Happy New Year! Can you check also my website please? I have the same situation.

    my problem solved.

    • This reply was modified 7 months, 1 week ago by Ignatios.
    • This reply was modified 7 months, 1 week ago by Ignatios.

    Hi Ignatios,

    Thanks for getting in touch with us today.

    I am glad that this is now resolved 🙂

    Feel free to contact us should any other issues come up. Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi,

    I am so sorry but I don’t see it.

    Can you please add that again?

    Thank you.

    Yes, here is the information I got from our host about this issue:

    I took a look at that link provided but it doesn’t give any information about the fix. Can you get in touch with Rankmath and see what needs to whitelisted or any code that needs to be added to an NGINX server to allow the API calls?
    We don’t block any API calls on this end but perhaps they have an IP address that needs to be whitelisted?
    Usually, an API call like this based on a Key that the developers supply. Have you checked to make sure they Key is up to date?
    Let us know and we’ll go from there.

    Hello Lauren,

    Thanks for getting back to us.

    I have raised this with our dev team and we will be getting back to you in a short while.

    We appreciate your patience. Thank you.

    Please whitelist requests from the following IP:

    104.20.193.153

    That should fix the issue. If you don’t know how to do that, please contact your hosting provider.

    Hello, they whitelisted that IP address this past Friday. Tried the SEO Analysis tool again and am still getting the API error message.

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    I have submitted this problem to our dev team, could you please generate a new access token so that we can check this further?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Sure, I reactivated the same access token. Please let me know if I need to add it to the sensitive data area again, or if you can see the previous one. Thanks!

    Hello,

    Please add it to the sensitive data section, we do not have access to the last token.

    Thank you.

Viewing 15 replies - 1 through 15 (of 23 total)

The ticket ‘API Error’ is closed to new replies.