Wrong Snippit on Twitter Using Elementor Share Btuoon

  • Hello,

    First of all, Rank Math is a amazing SEO plugin. I can recommend it to anyone.

    The reason why I’m contacting you is when I wanted to test the Elementor Share Button on a page of my website, it showed a wrong snippet like the page did not exist. It shows a the custom redirection snippit.

    All the other posts work fine. Any idea what it could be?

    This is the post and below are the share buttons. this post I only tested it for Twitter because it is the only one I have and use.

    This is what I’m seeing Twitter share window before sharing the link.

    After posting the link on Twitter it does bring me to the right post.

    I hope you can help me out.

    Greetings Jack

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    We are seeing the correct information in the card validator:

    Works fine even while using the sharing button:

    Although, we did see a CloudFlare issue a couple of times before the website opened correctly so that might be why you got the issue earlier.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Thank you for your fast reply Uzair.

    It is very odd because after I saw your reply, it worked.

    Could you tell me what kind of Cloudflare problem I have, maybe I can contact them and fix.

    What else is strange is that it’s not showing the correct snippit picture when I want to post it. It’s the second image on this page it will pic and the featured image. Even in the snippit tool it will pick the featured image. Is it because it is to small or also a cloud flare problem?

    Here I found almost the same kind of problem. The featured image isn’t used and the description I made in the Rank Math snippit tool isn’t also used.

    Greetings,
    Jack

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    The image you have added is quite small(64x64px). Please upload at least 600x315px image. The recommended size is actually 1200x630px.

    As for the description, it seems to be showing up correctly:
    img

    Hope that helps. Please check and let us know. Thank you.

    Hey Micheal,

    again that is so odd but I m happy it works now and ty for explaining to me px sizes I need to use.

    Greetings,
    Jack

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

The ticket ‘Wrong Snippit on Twitter Using Elementor Share Btuoon’ is closed to new replies.