WhatsApp thumbnail not displaying when URL is shared

  • I utilize the Rank Math Plugin for my website and I changed my theme recently. Upon changing the theme, my website URL fails to load thumbnail when I share it on WhatsApp.
    Although, the thumbnail is working on facebook and twitter. I need help on making it work on WhatsApp. I have contacted the theme support, they redirect to my SEO service. Kindly support me on this.

    Thank you and Best regards

    • This topic was modified 1 week, 3 days ago by  Oara.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    I am unable to access your website, it is reporting the following error “ERR_SSL_UNRECOGNIZED_NAME_ALERT” could you please get some help from your host to fix it so that we can check the issue for you?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    I have contacted my host and they reported that it has been resolved. Kindly try accessing the website now.
    Thank you as I hope to see this resolved soonest

    Hello,

    Thank you for contacting Rank Math today.

    The og:description & meta description is missing from your page. Could you please add a description and check whether the issue will still be reported?
    Additionally, could you resize you image to be between 600x315px and 1200x630px.
    You are currently using a squared image and it is getting cropped.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Forgive me, can you please explain to me how I can do this, I seem not to understand, I am quite a novice in all of these. Thanks

    Hi there,

    Thanks for the follow up.

    Please head over to your homepage and click on the “Edit Snippet” button as shown below:
    Edit snippet

    You will then be able to enter your description on the last field as shown below:
    Description field

    To be able to change the default OpenGraph image, please head over to Rank Math > Titles & Meta > Global Meta > OpenGraph Thumbnail

    I hope this info helps. Thank you.

    Yes, it helps but I have a the Open Graph Thumbnail set. My issue is this;
    1. I do set featured image for all my posts and until I changed my theme, it used to display the “featured image” whenever I share on social media.

    But now, both the “OG Thumbnail & Featured image” does not display whenever I share on WhatsApp. AND whenever I share on Facebook, it displays the “OG Thumbnail” instead of the “Featured Image”

    I am using a “MH Magazaine” theme and I have had various chat with their support, they said it has nothing to do with their theme but with my SEO plugin. I have tried researching about what might have gone wrong on my own, but to no avail. Please I hope you understand and can help.

    Thank you for all the responses. Regards.

    Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Oara,

    Thanks for the patience.

    I do not think that this is Rank Math problem since I have disabled the Rank Math OpenGraph tags and activated your OpenGraph plugin but the same issue is reported.
    I can suggest that you temporarily switch to another theme to help to rule out theme compatibility issues.

    Thank you.

    Okay, Thank you. I will notify you immediately change the theme. Thanks a lot for the support.

    Hi there,

    Thanks for the response.

    Please let us know how this goes.

    Thank you.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this ticket.