Too many redirects when rank math is active and image alt attribute error

  • I noticed I was getting too many redirects error on this specific page https://www.cyberdreamdevelopers.com/request-consultation/ and upon troubleshooting, I eventually deactivated rank math and the page loaded after. It only happens for that page so far.

    Additionally, in the SEO optimization setting, I noticed that sometimes rank math doesn’t seem to play nicely with Elementor. The image alt attributes were pasted from the page title but I still get errors that it’s not so maybe there’s some minor error there as well. It did work for one page though.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    1). Could you please check whether you have the same category bearing the same name as this page ie “request-consultation”? If it exists, you can either rename this category or disable the Strip category base option under Rank Math > General Settings > Links to fix the redirection loop.

    2). This is a known issue, Rank Math is unable to detect alt attributes in this page builder but you can rest assured that this failed test on the SEO analysis will not affect your SEO since in real sense they are passed tests.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    How do I check if I have the same category bearing the same name as this page?

    Thanks for question number 2 as well.

    Hi there,

    Thanks for the question.

    You can perform a quick search on your Posts > Categories page and all your other post types taxonomy/tags pages.
    Additionally, please check on the Rank Math > Redirections page whether there are more than one redirections to the affected page.

    We are looking forward to helping you. Thank you.

    It is a page and there are no posts on the website so I don’t think that posts-categories check would help since there shouldn’t be any conflict.

    I have a flawed redirect. I renamed the page and updated the url and it seems the redirect from the old url to the new one was done incorrectly. I’ve fixed the error in entry and now it works!

    Awesome! Thanks for your help 🙂

    Hi there,

    Thanks for the follow up.

    I am glad that this is now resolved 🙂

    Feel free to contact us for any other questions, comments or suggestions.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

The ticket ‘Too many redirects when rank math is active and image alt attribute error’ is closed to new replies.