Switch to GA4

#430900
  • Hi,

    I have Google Analytics running on my website after having added the gtag code to the <head> of my website. I think that because of this the RankMath summary is showing 0 impressions in the last 30 days.

    I have created a GA4 property which I now would like to connect to my website. This seems to be impossible to do via RankMath => General settings => Analytics. I cannot select change the Account / Property / View.

    After having deleted the gtag code which has been placed in the <head> I still cannot select change the Account / Property / View.

    I have read your information on GA4 but have not found any information on how to switch from universal GA to GA4.

    Many thanks,
    Margriet

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting the support and we regret the inconvenience caused.

    Please reconnect your Google account from your WordPress Dashboard > Rank Math > General Settings > Analytics, and see if you’re able to configure the Search Console and Analytics settings:
    reconnect

    Once you’ll reconnect and configure the Analytics settings, the data fetch should start automatically.

    Please let us know how that goes.

    Thank you.

    Great – many thanks! That works.

    But it did make me realise there is another issue, but you might want me to open another ticket for that… It seems that only pages with /nl/ after the url are included in the RankMath sitemaps. Weirdly enough I could only select the url with /nl/ when reconnecting Google Search Console even thought Google Search Console refers to the url without /nl/.

    I hope that what I write is making sense.

    If needed, I can open a new ticket for this.

    Margriet

    Hello,

    I checked your website and the website by default redirects to the /nl/ version. Even if it is deliberately left out, the redirection takes back to the same version. This is applied throughout the website including the sitemap. You can have a look at the screencast in the sensitive data section of this ticket for a quick reference.

    It seems like /nl/ is the default language/variation of the website and all the posts are also created under it so the same can be seen in post URLs as well. I checked the canonical URL of a post and it is also having /nl/.

    As for the Google Search Console property, please ensure that the Google account (email address) you’ve connected with Rank Math is the same account used to verify the website on Google Search Console and Google Analytics.

    Also, check whether the email address is listed as the property owner on Search Console and if you have verified the correct variation of your website (HTTP or HTTPS, www or non-www).

    Once done, please reconnect your Google account from your WordPress Dashboard > Rank Math > General Settings > Analytics and see if the drawdown values of the Search Console and Analytics settings are updated.

    In case the issue persists, please follow this guide and see if that helps: https://rankmath.com/kb/delete-old-analytics-data/#remove-access

    Let us know how that goes.

    Thank you.

    Hi,

    Sorry for the late reply – busy day. Anyway, many thanks, no clue how I achieved the /nl/ ‘redirect’. Will first try to sort that out.

    Margriet

    Hello,

    Sure, and please feel free to let us know if you have any questions.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this ticket.