Submitted URL not found (404)

  • I am receiving a Submitted URL not found (404) error on google search console. Any suggestion? If I have mistakenly blocked the indexing of the page? The URL is MOVED TO SENSITIVE DATA SECTION Can I have any suggestions about what I should do to fix this.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,

    Thanks for getting in touch with us.

    I have checked your URL and it seems to be fine and set to index. It is possible you had 404s on those URL before and now you don’t.

    Nothing to worry about, just allow Google some time to recrawl your pages and see that they exist. You could also click the “Validate Fix” link after going into each URL via GSC.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    I had tried with “Validate Fix” Some days back but it again notifying me as an error. Could it be something that might be blocking google bot to crawl to the post?

    Hello,

    Your meta robots in the page you shared and also the robots.txt file are fine, so it could be you just need to wait more time (sometimes Google is like this, slow showing changes).

    As a side note, I saw you have in your robots.txt these sitemaps added:

    Sitemap: https://www.website.com/post-sitemap.xml
    Sitemap: https://www.website.com/page-sitemap.xml
    Sitemap: https://www.website.com/category-sitemap.xml

    You shouldn’t have them, since the only sitemap you have to had there (and in Google Search Console added is sitemap_index.xml, like this:
    Sitemap: https://www.website.com/sitemap_index.xml

    Looking forward to help you.

    Thank you Alberto, for the additional information. Is there any full guide on this sitemap topic on RankMath?.

    Hello,

    What kind of information about the sitemap are you looking for? Maybe I can help you with it, if you post all your questions I will be happy to answer them!

    Looking forward to help you.

    Hello Alberto,
    As you had suggested that only “sitemap_index.xml” should be submitted, I have done like that. Could you please confirm that is it fine now or not?

    Hello,

    They still are in the robots.txt file, you should edit it. You can by going to the WordPress Dashboard > Rank Math > General > robots.txt and replacing:

    Sitemap: https://www.website.com/post-sitemap.xml
    Sitemap: https://www.website.com/page-sitemap.xml
    Sitemap: https://www.website.com/category-sitemap.xml

    with (changing website.com with your domain):

    Sitemap: https://www.website.com/sitemap_index.xml

    Looking forward to help you.

    Hello,

    I have checked your sitemaps and they seem fine. I have also validated the URLs with this tool: https://www.xml-sitemaps.com/validate-xml-sitemap.html and seems fine. If you have any cache plugin, please exclude the sitemap URLs from being cached then clear your site cache.

    Looking forward to helping you. Thank you.

    ​​​​​​

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this ticket.