Social Media Posting now showing properly

  • Hello,
    Can you help me please why LinkedIn is not showing the images, LinkedIn adn Facebook is not showing the description and Twitter is showing the description but not the images in a shared post?

    Thank you!
    Krisztina

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    our page doesn’t seem to have opengraph images assigned. Have you assigned a social share image on the page under the social tab or in Rank math > Titles & Meta > Local SEO ? Please check. I wanted to look into this but the access doesn’t seem to work.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hi,
    Yes, the images is not in meta tags, I noticed.
    However I added to the social section
    https://prnt.sc/vg99su
    https://www.catseo.co.uk/seo-tips-for-job-posting/
    First I thought Webp image is not supported, but I have changed the file format and uploaded Jpg.

    The login should work. I tested.

    Thanks very much!
    Krisztina

    Hello,

    The issue with your Globally set opengraph image is the size. You have set an image of size 60X60px. The minimum required size is 600x315px

    If you check the other post you shared, https://www.catseo.co.uk/seo-tips-for-job-posting/, the image set in the social sharing tab is showing fine in the page source and in facebook debugger: https://i.rankmath.com/dh9UX7

    Please edit the image to add on the scale or find an image of the minimum required size. The recommended size is actually 1200x630px

    Looking forward to helping you. Thank you.

    ​​​​​​

    Thank you, image works!
    Enjoy your day!
    Krisztina

    Ah sorry, only works on FB but not on LinkedIn or Tw.
    Can you review it? I just shared this post today with an image https://www.catseo.co.uk/17-best-local-seo-tips/

    Thanks
    Krisztina

    Hello,

    Sorry for this late reply. Did you get it working? Or do you still have the issue? If you still have it, we will be more than happy to continue helping you with this.

    Looking forward to help you.

    Thanks for your reply, the social posting works now.
    Enjoy your day.

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

The ticket ‘Social Media Posting now showing properly’ is closed to new replies.