Snippet configuration and focus word not saving

  • Resolved Zapa

    I have this problem since some days ago. I write down the focus word, the description and the permalink and only the permalink is saved. Once I reload the page all is lost. No matter if I save the draft or even publish the article. That also applies to the Facebook and Twitter cards which appear with the first paragraph of the post instead of the custom description.

    I appreciate the help. Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Data added.

    Thanks

    Hello,

    I tried to replicate the issue with no luck. Could you check the screencast I added in the Sensitive Data section?

    Looking forward to help you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Alberto.

    Could you please try the following steps in order to reproduce the issue?

    – Go to posts section
    – Edit the post showed in the screenshot at sensitive data box
    – Edit snippet
    – Add a focus word
    – Update post
    – Reload browser

    Hello,

    I am getting the following when I try accessing your site:

    img

    Could please ask your hosting provider to temporarily disable this so we can investigate further.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi Michael.

    Sorry about your access problems. That is due to a security policy from my hosting provider to prevent access and attacks from bots.

    I leave the instructions to enable the access in the sensitive area.

    Thank you.

    Hello,

    After checking it, I found the issue is due to Rank Math is not being able to call the WordPress REST API on your website (it seems blocked).

    These are the error logs:

    POST https://www.*****.com/wp-json/rankmath/v1/updateMeta?_locale=user 403
    (anonymous) @ leadin.js?ver=7.36.1:1
    
    api-fetch.min.js?ver=b437dd9d1118e698b1b85961e759bf03:2 Uncaught (in promise) {code: "invalid_json", message: "Las respuesta no es una respuesta JSON válida."}

    You should check if one of your security plugins is blocking it (a firewall, REST API disabled…) and if you don’t find it, I would suggest asking your hosting support if the servers are blocking those requests.

    Looking forward to help you.

    Hi Alberto. Thanks for your tip!

    It is a bit weird so I will post what I did to solve the issue in case someone has the same problem.

    I have several websites in the same host account. The main website is installed in the root folder and the rest of websites in separate folders. The website where I had the problem is hosted inside one of those separate folders.

    I disabled All in one wp security and had no effect. But when I tried to enable it again I noticed it had problems to re-stablish file permissions. Wordfence was blocking the request.

    That is strange because I preciselly uninstalled wordfence because all this problems I had in the past with it. Well… it was uninstalled but not deleted. So I deleted it with no luck.

    Then I went back to the root website and noticed it had wordfence installed. Uninstalled it. Installed all in one wp security and that seemed to do the trick.

    Still it takes some seconds after reloading the browser for rankmath to recover all data (focus word, exceprt, etc) but it works.

    Thanks all support staff ant RankMath for your time and help. Great service even for a free plugin!!

    Hello,

    First of all, thank you for sharing with us how you solved it, I am sure it will be really useful for a lot of users.

    Also, we are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this ticket.