sitemap_index.xml not working

#89294
  • I am not able to open the sitemap_index.xml page also Sitemap in not showing in Search console as well as in the Plugin.

    Please Help me resolve the issue,
    thank you
    Sunil

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Why there is no reply? request you to please revert at earliest.

    Hello,

    I noted you have caching enabled on your, please exclude all your sitemap URLs from being cached then clear your cache, resave your permalink and sitemap settings.

    For the sitemap to show in the search console in Rank math, you have to make sure you have submitted your main sitemap file(sitema_index.xml) in your GSC.

    Please do this and let us know if the issue still persists.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi Michael,
    #1 (please exclude all your sitemap URLs from being cached then clear your cache,) -> Can you pl explain how?

    #2 (For the sitemap to show in the search console in Rank math, you have to make sure you have submitted your main sitemap file(sitema_index.xml) in your GSC. ) ->
    I have already submitted Sitemap_index.xml to GCS and it was working fine.. I am facing this issue for the last 10-15 days

    Regards,
    Sunil

    Hello,

    If your cache is managed through a plugin on your site, just look for the caching settings and find a field to exclude URLs/pages.

    If the cache is managed by your host, please share with them your sitemap URLs and ask them to exclude them from being cached.

    Once done, please clear your cache then resave your permalink and sitemap settings.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Hello,
    It was working fine with these setting earlier.. why all of the sudden my Sitemap is not seen? I have given you site access so that you can pl let me know the exact issue. Can you please check and revert. I don’t think cache should stop Sitemap to work as I haven’t faced this issue anywhere else.

    Regards
    Sunil

    Hello,

    If it was working fine, did you change or install anything? I checked your sitemap Source code and it seems to show some deprecated error, please check the screenshot attached in the sensitive section.

    To determine if the error is coming from your theme or one of the installed plugins, please deactivate and activate your plugins one by one and try switching to a default theme.

    If you want to look into it further, please create a staging site and share the access to avoid affecting your production/live site

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

The ticket ‘sitemap_index.xml not working’ is closed to new replies.