Sitemap was working, then i did something and now its not

  • Hey there!
    I’m loving RankMath and it is proving to be very useful. I, however, did something and I cannot figure out what I did, but my sitemap has disappeared. It was working great. I had the main sitemap, one for posts, and one for pages. Then I was looking at it and there was a feature something about images, and that I needed to turn on attachments. Anyways I did all that. But then saw a couple days later that a lot of sitemaps were made (each with 200 pages). I realized this was a bad idea. So I tried to turn it off (the attachment option), but now my main sitemap is returning 404! I did something. Can’t figure it out. I tried saving permalinks again, I tried going into the cpanel. I can’t figure it out.

    Please help!

    UPDATE: It randomly seems to have created the sitemap, but looking at the sitemaps under search console I see it is not showing up, and all of the “attachment” site maps are still present. Google search console still says “sitemap cannot be read”

    Thanks.

    • This topic was modified 3 months, 3 weeks ago by Richard. Reason: update
    • This topic was modified 3 months, 3 weeks ago by Richard.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    Thank you for contacting Rank Math today.

    Your sitemap works normally when I check the link. In regards to the error on your search console, this is normal and the “couldn’t fetch” error should resolve itself in a couple of days.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Thanks for the quick response! Customer service with you guys is fantastic! Super impressed.

    Just to clarify. Under the search console tab within Rank Math, I’m unable to refresh the sitemap, and the old sitemaps (plural) with all the attachment sitemaps are still showing. This will go away in a couple of days?

    Something is still not right… When I try manually fetching a website page (wither bing or google) it is telling me that it is denied by robot.txt. Seems very weird to me.

    More updates:
    … I tried doing a reset on some options on RankMath (one being authorization with google) It how tells me that google temporarily has disabled the Rank Math app, and I cannot log into search consol.

    Downloaded and updated Rankmath to the newest update! Go connected back with Google… however when I go to the search console tab and click refresh my sitemaps, it somehow is referencing my other website I have on google. with a message that says “http://paragoncreative.ma/sitemap_index.xml'%5Bmy other website] is not a submitted or a known sitemap index”

    Any idea?

    Think I got it sorted…

    Hi Richard,

    Thanks for getting in touch with us.

    I am glad that this is now resolved 🙂

    Feel free to contact us should any other issues come up. Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

The ticket ‘Sitemap was working, then i did something and now its not’ is closed to new replies.