Sitemap URL not working

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    This may be related to a conflict on your site, the most common cause of this is caching plugins.
    Could you please investigate this by performing these steps:
    https://rankmath.com/kb/check-plugin-conflicts/

    Looking forward to helping you. Thank you.

    ​​​​​​​

    I am also getting a 404 not found error in regards to sitemap_index.xml

    If I go to settings, permalinks and save without changing anything it starts working again. As recommended by Rank Math.

    This happens every time my site is pushed from staging to live as well as happening intimately.I have to check the site map is working all the time. Google has given errors from this now which is not good.

    I am using Wp Optimize caching plugin and have been using it for a long time with no issues.

    This error only started happening a few updates back and was fine before this as I have been using Rank Math for a while now.

    If we can have a permanent fix for this as I can’t keep doing this every time it decides to turn off and it appears there is a bug by how many people are having this problem. Also my previous SEO plugin i was using never had a site map issue so this seems a bit strange.

    Hi @admin1292,

    I am sorry for the inconvenience caused.

    Could you please open a new ticket and share some temporary admin access so that we can investigate this issue further?

    We are looking forward to helping you. Thank you.

    hello, I am still facing the same issue (page not found)

    Hi Kheltalk,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you please do the following:

    1. Head over to WordPress Dashboard > Settings > Permalinks

    Hit the save button once.

    2. Go to WordPress Dashboard > Rank Math > Sitemap Settings

    hit the save button once.

    That should fix the issue.

    If it doesn’t, please do let us know so we can look at this further.

    I have already done, but the problem is still coming.

    I had the same issue. Got a notification from Google my sitemap could no longer be fetched. Deactivated the site map en reactivated without any results. Deactivated my caching plugin without any luck. Went over to this forum and this post and tried saving the permalinks again. For me that worked.

    Hi Kheltalk,

    Thanks for the reply.

    Please share some temporary admin logins to your site on the sensitive data section so that we can check this further.

    @bartdeveerde I am glad that this fixed the problem for you 🙂

    Thank you.

    The same happened to me also. It is happening again and again. http://prntscr.com/qzrw2q

    Hi Jyoti,

    Thank you for the reply.

    I can see from the screenshot that some links have already been fetched.
    Please head over to Rank Math > Sitemap setting and reduce the number of links in each sitemap if it is more than 500 and then give this some time.

    Let me know how this goes. Thank you.

    It’s currently 1000. Should I reduce the number to 500? If I reduce, what will happen in sitemap? https://www.wpmyweb.com/sitemap_index.xml

    I’m having the same problem. I can’t load the sitemap into SEM Rush. The site is saying that the file is invalid. After trying the suggestions in the support area and the knowledge base, I was convinced that everything was generating. I was able to confirm that I was getting a 200 HTML return code so I’m pretty sure there is no firewall/proxy setting that is causing the issue.

    The message from SEMRush was that the file was invalid. I ran the file through the w3 sitemap validator and it came up with errors.
    https://validator.w3.org/nu/?doc=https%3A%2F%2Fequityadvisory.com.au%2Fsitemap_index.xml

    I then:

    • manually edited the file to remove the styling information – still couldn’t upload
    • used a simpler urlset declaration – still couldn’t upload.
    • removed the image declarations – SUCCESS

    I was then able to upload the file into SEMRush.

    My guess is that there are some xml in the file that is not universally accepted. Perhaps its a version thing but neither the w3 validator or SEMRush like the current Rank Math sitemap version.

    Happy to answer other questions if you have them. I have the edited version of the sitemap.xml if you would like to see that. Clearly though, I’m not doing this manually every time the site changes.

    Hopefully this information helps.

    Hi Brett,

    I will be happy to assist you with the issue you are facing.

    It seems like a conflict with one of the plugins or the theme you are using. To determine that, can you please follow this troubleshooting guide?
    https://rankmath.com/kb/check-plugin-conflicts/

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Would be great if you can open a new ticket for this as well since we do not want the OP of this ticket to get unnecessary email notifications.

    Thank you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)

The ticket ‘Sitemap URL not working’ is closed to new replies.