Sitemap problem

  • Hello,

    After i installed RankMath i cant see the sitemap.

    When i visit the link it redirects me to homepage.

    Also in RankMath -> 404 monitor i see a lot of 404 pages that there wasn’t there.

    Can you check it?

    Best regards

    • This topic was modified 2 months, 3 weeks ago by Thodoris.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    You can always fix the 404 error on the sitemap page by doing the following:

    1. Head over to WordPress Dashboard > Settings > Permalinks

    Hit the save button once.

    2. Go to WordPress Dashboard > Rank Math > Sitemap Settings

    Hit the save button once.

    In regards the second problem, the 404 errors are quite manageable and normal. I do not think that this should cause any worry.

    I hope this info helps. Thank you.

    Hello,

    I did your steps and worked just fine.
    I also changed the permalinks to post name.

    Why in 404 monitor i see a lot of pdf?
    Also why there are so many “pages” that i cant find?

    Best regards

    Hello,

    Thank you for contacting Rank Math today.

    This must be deleted pages/pdfs that are still referenced in your post content. These will be detected as 404s when bots are crawling your content. If one error is very common then you can redirect this to the parent post or the homepage using the redirections module.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    Can you check the url that i added in the Sensitive Data?

    I dont know why it shows it like that.

    Best regards

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Thank you for contacting Rank Math today.

    This is completely normal, the characters appear strangely because of browser encoding because of the presence of special characters. This should not affect functionality.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    The problem is that this url does not exist, i changed it to check it

    Best regards

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    The links works as expected for me without redirecting to a 404 page. I have share the link that the page redirects to on the sensitive data section.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello,

    It doesnt redirect to 404 but to home page as selected from the options.

    The problem is that i dont know where the system found this url:/?CMCCode=100301&extLang

    Also i see that in a keyword that we need a lot it goes down every week, the keyword is Χαλαζίας, can you check it?

    Best regards

    Hello,

    Thanks for getting back to me.

    I am not quite sure where this modification is coming from but it must be stemming from one of your installed plugins or the theme.
    I have also checked the other issue and your site was having a problem of loading the sitemap_index file. I have fixed this error but it does not seem like the search console is fetching the sitemap.
    Could you please login to your search console and check if there are any coverage errors and whether the sitemap file links have been fetched?

    We are looking forward to helping you. Thank you.

    Hello,

    There is an error, says that the sitemap is html.

    I added it again.

    It happened again in the past, why again?
    Is this bad for seo positions?

    Also i see some errors in mobile speed, Error FID >300ms and Error FCP>3sec.

    Best regards

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 22 total)

The ticket ‘Sitemap problem’ is closed to new replies.