Sitemap Not Updating or Incorrect

#96230
  • Hi
    I’m having post sitemap issues.
    Sometimes the sitemap (unavailable) is fulfilled only when I change the numbers in the Links Per Sitemap section, and it becomes old again when a new post is shared.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hey buddy if it goes this way there is no reason left to switch to yoast seo plugin and I can also warn my friends.

    I posted a new post again, it gave an error. I’ve tried all the other methods you’ve shown, but nothing has changed. Please help with this.
    https://imgur.com/kr9AHwz
    https://imgur.com/b4Hibe5

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Do you have any caching setup on your site? If you do, please exclude all you sitemap URLs from being cached.

    Else, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I added a few more sitemap exceptions to your cache plugin. After that, I cleared the cache and resaved the permalinks and now everything should work fine, could you check it?

    /sitemap_index.xml
    /post-sitemap.xml
    /main-sitemap.xsl
    /page-sitemap.xml
    /web-story-sitemap.xml
    /category-sitemap.xml

    Looking forward to help you.

    Ok but the problem arises when I post a new post.

    and I already added it (/post-sitemap.xml)

    Hello,

    I saw you set it as solved, is it? If not, could you share again the login credentials so we can log in there and try to find the cause of the issue?

    Looking forward t help you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    The map is all gone

    Hello,

    All the sitemaps are working correctly and your latest published post is showing up in the post-sitemap.xml file as well.

    We have shared a screencast in the sensitive data section that you can check.

    Please wait for the last crawled date to change on your Google Search Console because it is still showing 25th October which means Google has not yet seen the “fixed” version of your website.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Thank you for your interest.

    1 more question!
    How can I do the search results as shown in the picture?

    Only
    Title | Name
    https://imgur.com/28H5ro6

    Hello,

    That’s completely normal for Google to include your brand name in the title’s automatically – even if you deliberately leave them out from your titles.

    Here’s an article mentioning that as well.
    https://seo-gold.com/marcus-lemonis-website-seo-review/google-automatically-adds-brand-name-to-titles/

    And a link to Google’s forums with replies from Experts saying that it is like that on purpose:
    https://support.google.com/webmasters/thread/5328043?hl=en&msgid=5328043

    If you wish to know Google’s guidelines on writing Good titles, here are the guidelines straight from the horse’s mouth:
    https://support.google.com/webmasters/answer/35624?hl=en

    With that said, it largely depends on keyword intent too. For some keyword searches, your custom title might appear while for others – Google might append your brand name to the title and there is nothing you can do to force them to do otherwise. That is regardless of what SEO plugin you use.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)

The ticket ‘Sitemap Not Updating or Incorrect’ is closed to new replies.