Sitemap not updating [Critical?]

  • Hi

    We’ve moved to RankMath (From Yoast), a few weeks back. A few days ago I spotted that the sitemap was not updated.

    Here’s what I’ve already secured:

    • Caching is disabled in LiteSpeed (Returning x-litespeed-cache-control: no-cache
    • Disabling cache at Cloudflare end, and secured the expected headers
    • Purged All cache from LS Cache, including Object, Pages and so on (Yep, the server had things to do, in the next two hours….)
    • Walked to “Settings > Permalinks”, and saved the page.

    Nothing changed. Same sitemap was returned…

    The only way I was able to fix it, was to change the “Links Per Sitemap” to something else (500 to 400, but other value(s) can do it, too).

    I can find A LOT of topics about this, but all users are pointed towards solutions like “clear own caching”, check X, Y and Z – and so on. But… That’s the real problem? Something must be wrong or conflicting, within the plugin – or in combination with another solution?. Are some custom hooks broken, so a new sitemap-gen are not triggered after post-edits?

    We’re running on the latest version of WordPress, with the latest version of Rank Math.

    Please look into this. It’s critical.

    Let me know, if I can do anything to provide debug data, or anything like that.

    • This topic was modified 1 week, 2 days ago by Tobias. Reason: Formatting issues
Viewing 4 replies - 1 through 4 (of 4 total)
  • 1. Local setup
    I’ve tried to create a local instance of LiteSpeed including all our plugins. I’ve added two sitemap-plugins, just to do it even more complex.

    And… It’s updating like it should.

    What kind of things could be related to this? It’s working on the fresh local env., but not on the production-server?

    Our prod server are using LiteSpeed, too.

    2. Dev setup with staging-data
    I’ve a dev-staging site, which are not totally in sync, but where Yoast was still installed.

    I started by disabling it, installing RankMath, walked trough the wizard with “Easy”-mode turned on, and imported all the data from Yoast, too…

    Creating a new post….

    And…. It worked like it should, too.

    So I really need some inputs on how to debug this (very) wierd issue.

    Today I changed the value from 400 to 401, and a updated sitemap was generated right away. No need to change the cache, or anything like that.

    So it must be something with the hook to post changes/published or so?

    Please let me know, what I can do, to provide more details, related to this.

    _I’ve tried to change RankMath to advanced in both test-instances mentioned yesterday, but they are still working as they should. So I need some inputs, to provide more details. Feel free to contact me by mail._

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Can you please follow these steps?
    1. Flush the Sitemap cache by following this video screencast:
    https://i.rankmath.com/pipRDp

    2. Exclude the Sitemap files of the Rank Math plugin in your caching plugin. The cache could be via a plugin or from the server. For plugins or Cloudflare, please follow this article:
    https://rankmath.com/kb/exclude-sitemaps-from-caching/

    If the issue persists, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WordPress logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hi

    Thanks for the standard reply. I’ve already provided answers to all the question, and technical details, too. I’ve already tested it myself, in two other instances, too.

    Caching are flushed, both locally (Compressed, Object, HTML, JS and CSS), Sitemaps ARE excluded in CF, and if i change the sitemap value to 401, instead of 400, the changes are shown right away….

    Therefore, it’s not anything related to the settings in the plugin, or on our blog.

    Please provide some insights om how I can debug?

    – Can I create a custom log with debug information (s) from RankMath?
    – Are RankMath saving sine run-time data, at the time of the Post-Update/Created are triggeree?
    – Are there anything which could impact the resultats, of the hook? As stated, the hook works just fine for our other sitemap-plugins. They are tested both site-by-site, and one by one. RankMath are failing in both scenarios, where all other sitemap-plugins are updating as they should.

    So, what’s the next step?

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this ticket.