Sitemap not updating

  • Hi RankMath

    I’m using the sitemap created through wordpress rankmath. My problem is that it does not seem to be updating correctly?

    Are you able to help me out?

    Best Regards
    Jonas

    • This topic was modified 4 days, 9 hours ago by Jonas Rønn.
Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you please do the following:

    1. Head over to WordPress Dashboard > Settings > Permalinks

    Hit the save button once.

    2. Go to WordPress Dashboard > Rank Math > Sitemap Settings

    Hit the save button once.

    That should fix the issue.

    If it doesn’t, please do let us know so we can look at this further.

    Hi Michael

    Have done it now.. still doesn’t seem to be updating the sitemap… How long after having clicked the “save” button should it be updating?

    Are there other fixes that I can try?

    Thanks

    Best Regards
    Jonas

    Hello,

    Thank you for contacting Rank Math today.

    This should update immediately. It is likely that your caching plugin is affecting the generation of the sitemap entries. Could you please temporarily disable it and check if the correct links will be displayed after performing the steps above?

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi Michael

    Unfortunately, this does not work… I have disabled the Cache through my WebHost siteground and checked in the WordPress dashboard? I have experienced this once before a couple of days ago but then it worked after clicking “save changes”

    What to do?

    best Regards
    Jonas

    Hi RankMath

    The sitemap is still not working – are you able to help?

    Thanks in advance!

    Best Regards
    Jonas

    Hi Jonas,

    We are extremely sorry about that.

    I will be happy to assist you with the issue you are facing.

    It seems like a conflict with one of the plugins or the theme you are using. To determine that, can you please follow this troubleshooting guide?

    Confirming a Theme/Plugin Conflict With Rank Math

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    If that doesn’t work, we might need to take a closer look at the settings. Please include your WP logins in the designated Sensitive Data section.

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    Hi Todd

    Thanks for responding

    See above for login details – please help me out and fix the problem.

    best Regards
    Jonas

    • This reply was modified 4 days, 9 hours ago by Jonas Rønn.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    I just reset the settings for the “smush plugin” – now the sitemap has been updated. So all good now 🙂

    Could this plugin have caused the error? and is there anything I should be aware of in the future in regard to this error so that it does not happen again?

    Thanks for your kind help so far!

    Best Regards
    Jonas

    Okay never mind – still causing errors – please check my site 🙂

    Thank you!

    Best REgards
    Jonas

    Hello,

    Thank you for contacting Rank Math today.

    You forgot to share your site URL on the sensitive data section. Please share this info so that we can check this further.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Rankmath

    I have now updated the Sensitive data – please have a look at my website.

    Thanks in advance!

    Best Regards
    Jonas

    Hi Jonas,

    Thanks for the patience.

    I am afraid that I cannot replicate these issues on my end. I have created some test categories which were immediately added to the sitemap.

    It is a bit strange that this is not working on your end. Could you please try to login to your site from a different browser?

    Let me know how this goes. Thank you.

    Hi Michael

    You are right – it works when I try in Safari?!!? How come this happens only in chrome and is there anyway to correct this?

    Thank you very much for your help!

    Best Regards
    Jonas

Viewing 15 replies - 1 through 15 (of 16 total)

You must be logged in to reply to this ticket.