Sitemap loading with 404 error page

  • Hi there,

    I am very new to wordpress website production and have only begun to use rank math. I also have absolute no idea about coding.

    I have had trouble getting the sitemap_index.xml under General settings or page-sitemap.xml under Page settings to work as I get a follow up 404 error page (nginx/1.16.0). I have followed a few forum questions and some people seem to have the same problem but there hasn’t been a resolution that worked for me, which include ‘save changes’ with permalinks or clearing cache. One way of getting the sitemap to work is to change the permalinks settings to plain, however this changes the URL of my website pages which is not ideal.

    I am currently using a custom permalinks structure /%pagename%/.

    Any help is greatly appreciated.

    Thanks in advance.
    Keith

Viewing 1 replies (of 1 total)
  • Hi,

    That is a local site link that you shared.

    We can’t log in using that link. If you have a live website, we would love to take a closer look.

    Please ensure you have at least one indexable post/page to make the sitemap work.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 1 replies (of 1 total)

The ticket ‘Sitemap loading with 404 error page’ is closed to new replies.