sitemap issue

#390623
Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello,

    Thanks for contacting us and sorry for any inconvenience that might have been caused due to that.

    I can check that your sitemap is working fine. Please remove all previously submitted sitemaps from your GSC account and resubmit your main sitemap. The issue should be resolved once Google recrawls the sitemap.

    Let us know how that goes. Looking forward to helping you.

    Hi, Jaideep

    Great thanks for your reply. I thought this ticket had not been successfully submitted. Please forgive me and skip my repeated tickets.

    Ok, I resubmitted my sitemap which is sitemap_index.xml to the GSC. I will keep watching it.

    Regards
    Michael

    Hello,

    Let us know how that goes. Looking forward to your update.

    Thanks.

    Hi, Jaideep

    The sitemap gets more and more error now. We need your help to take a further inspection, please. The login details were provided.

    Regards
    Michael

    Hello,

    The sitemaps are working fine on the non-www version.

    The www version of sitemaps is returning a blank page as they are not redirected to the final variation.

    Please follow this guide and redirect to a final variation:
    https://rankmath.com/kb/couldnt-fetch-error-google-search-console/#num-5-4-redirect-all-three-other-versions-to-your-preferred-variation

    Once done, clear your website cache and resubmit the sitemap.

    Looking forward to helping you.

    Hi, Anas

    Thanks for your reply. What I have done as below:

    1. Set www as primary domain in the cloudways

    2. Set the rule to redirect all the other 3 versions to https://www.domain.com/sitemap_index.xml

    3. Test all the four versions sitemap in the chrome browser. All can be accessed, so the blank page issue is gone.

    4. Clear website cache.

    5. Resubmit the sitemap in the GSC.

    The result: Google can not fetch

    Please help to take further inspection, please.

    Hi, Team

    Is there anyone who can look after us to resolve this issue please?

    Best regards

    Hello,

    When trying to visit your sitemap as Googlebot, it is returning a 503 error:

    The error is related to the server, and something on your server is blocking Google from accessing your sitemap. Please get in touch with your host and inform them about this. They will be able to figure out what is causing this issue.

    Let us know how that goes. Looking forward to your update.

    Thanks.

    Hi, Jaideep

    After checking at https://httpstatus.io/.

    I found all the four versions of sitemap are ok.

    https://www.domain.com/sitemap_index.xml is 200

    The other 3 are 301 and 200

    I can not find 503 error right now. Please help me check again. Our web ranking (DA) has been dropped by 2 now. Really frustrating.

    Best regards

    Hello,

    I can check that your sitemap is working and validating fine now:

    Please clear your site’s cache and remove all previously submitted sitemaps and resubmit your main sitemap. Google should be able to crawl it now without any issues.

    Let us know how that goes. Looking forward to helping you.

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this ticket.