Sitemap is not working properly

  • when i enter my sitemap details, http://www.website.com/sitemap_index.html it is showing a blank page only.
    also in the sitemap section of GSC I see the post-sitemap.xml with a different number and the sitemap_index.html with a different number.

    the sitemap_index.html last ran on 24-Aug but I have been posting a lot of articles after that date.
    can you please help me fix this because when I search for the post URL in GSC it says it is not available

    Getting this message
    URL not in property
    Inspect a URL in the currently selected property or switch properties

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    On Google Search Console, you just need to add the sitemap_index.xml sitemap. Also, could you try to resave the permalinks to see if your issue is solved?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Also, could you try to resave the permalinks to see if your issue is solved?

    I don’t understand what you mean by this. can you please elaborate

    I did this one

    In WordPress, you can simply resave your permalinks by going to your Permalinks page which can be found under Settings and clicking on the ‘Save Changes’ button (You don’t even have to make any changes for it to take effect).

    Thanks

    • This reply was modified 5 days, 14 hours ago by Mystique.

    Hello,

    Yes, I mean just that. Going to your WordPress Dashboard > Settings > Permalinks and clicking the Save button without doing any changes. It will force Rank Math to regenerate the sitemaps.

    Looking forward to help you.

    Hello,

    I have updated the permalinks as requested. when I search for an URL I am getting an error message that it is not there in the property. Can you please check further?

    Thank you.

    • This reply was modified 4 days, 22 hours ago by Mystique.

    Hello,

    Make sure the property you have in GSC is the same you are using in your website (including the https and also www).

    Also, you can try by verifying it with another method like the DNS one, since it is a method that verifies all the property variations.

    Looking forward to help you.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this ticket.