Sitemap home page with WPML trouble

  • Hello!
    I use WPML plugin to work with several languages.
    I use option to split languages in directories. For example:
    site.url/ – English version home page (This is main language. home_url() == ‘site.url’);
    site.url/tr/ – Turkish version home page;
    site.url/ru/ – Russian version home page.

    But in sitemap for this pages urls are:
    site.url/ for English (Because it is home_url, result is good).
    site.url/tr/page_name – Turkish ($page->post_name == ‘page_name’)
    site.url/ru/page_name – Russian ($page->post_name == ‘page_name’)

    But i don’t want to show page_name in front pages on other languages.

    I want this urls in sitemap:
    site.url/ for English
    site.url/tr/ for Turkish
    site.url/ru/ for Russian

    How can i generate correct sitemap?

    • This topic was modified 2 weeks, 3 days ago by  Pratik.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Kindly allow me to consult our dev team about this and I will get back to you in a short while.

    We appreciate your patience.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello,

    The site_url/tr & site_url/ru pages on your site are set to noindex. Please check the Screencast I added in the Sensitive Data Section. The Sitemap shows only the pages which are set to index, kindly change the robots value to index from Settings for those 2 pages. That should fix the issue.

    If there is anything else, please let us know. Thank you.

    del

    • This reply was modified 2 weeks, 3 days ago by  Vladimir.
    • This reply was modified 2 weeks, 3 days ago by  Vladimir.

    Thank you.
    In sensitive data were developer version of site. “Search Engine Visibility” in options is turned off.
    I add production version link, here site map are still incorrect. Robots are allowed in this version of site.

    I make test site for you.
    https://vm.rocketingit.com/page-sitemap.xml
    Screenshot from sitemap:
    https://monosnap.com/file/xDiOpF4OqJjlcXOvtDTcQeTV9hJuQB

    I have updated the sensitive data. You can login to test site.

    Thank you.

    • This reply was modified 2 weeks, 2 days ago by  Vladimir.
    • This reply was modified 2 weeks, 2 days ago by  Vladimir.

    Hello,

    I have updated the sensitive data.

    Thank you.

    • This reply was modified 2 weeks, 1 day ago by  Vladimir.
    • This reply was modified 2 weeks, 1 day ago by  Vladimir.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)

The ticket ‘Sitemap home page with WPML trouble’ is closed to new replies.