Sitemap Created But Shows Error 403 in Search Console

  • Hey RankMath Team,

    My Site (ShoutMeBack) is encountered with a Sitemap issue.

    I have created the Sitemap a long time ago itself and when I visit the sitemap URL it shows up but when I go to the Sitemap section in Search Console, it says HTTP 403 error.

    My Sitemap URL

    Many publishers who are using Rankmath for SEO are facing this issue. For Yoast using publishers, everything is normal for them.

    Please provide me with any solution if possible as soon as possible

Viewing 15 replies - 1 through 15 (of 15 total)
  • Thanks for getting in touch.

    Your sitemap is working fine, you can try validating it on this link: https://www.xml-sitemaps.com/validate-xml-sitemap.html

    Are you a verified owner of your site on GSC? Have you verified the correct version of your website on Google? Please check if you have verified the www (or non-www) and https (or http) version of your website. If there is a mismatch, please fix that.

    Please make sure you have cleared the cache and excluded Google bot from seeing a cached version of your sitemap.

    If you have done all these and you are able to view your sitemap without any problem, then Rank Math is outputting your sitemap correctly and the error must be coming from Google. You can try and use a 3rd party sitemap plugin to confirm. Just make sure you have disabled the Sitemap module of Rank Math in WordPress Dashboard > Rank Math > Dashboard when using a 3rd party sitemap plugin.

    If the other plugin works, please do let us know.

    Thank you.

    Hey,

    I used a 3rd party plugin called Google XML Sitemap to generate the Sitemap and when I submit it to Google, it’s status converted to Success means Google had successfully read the sitemap.

    For Rank Math, it couldn’t even fetch it. Please look in the problem because many publishers use Rank Math over Yoast Free version. Please solve the issue fast.

    Hello,

    We are sorry about that.

    Many cache plugins exclude the sitemap.xml URL by default and that might be why it is working with the XML Cache plugin.

    I checked your sitemap using this 3rd party tool and couldn’t find any issues with it:

    The issue you described is not unique to Rank Math. There are 100s of users of other SEO plugins that face this issue as this issue seems to be stemming from Google and it goes away on its own after a few days.

    You can search "couldn't fetch" pluginname and see for yourself how many users of other SEO plugins are facing this issue:

    If you continue to see this issue after 72 hours of adding the sitemap URL in Google – please do let us know.

    Hey,

    Still facing the problem. The sitemap gets created but after sometime the page responds 404 in the sitemap url.

    Please tell the solution. I am facing this issue from 1 month but noticed it 7 days ago

    Hello,

    If you are using W3 Total Cache, please head to Performance > Page Cache and add /.*sitemap*. to never cache this pages. If its WP fastest cache, you should see an exclude tab under which you can add to exclude pages. For any other plugin, please check the plugin FAQs for how to exclude URLs and pages from caching.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Sir I already excluded the url from page cache. But still I am getting error 404.

    Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hi,

    I also wanted to ask if can you please follow these steps?

    1. Flush the Sitemap cache by following this video screencast:
    https://i.rankmath.com/xXXhDt

    2. Exclude the Sitemap files of the Rank Math plugin in your caching plugin. The cache could be via a plugin or from the server.

    That should fix the issue. Please let me know if that does not. We are here to assist.

    This is not usually required but might be needed when you make substantial changes to your website like installing cache plugins, fiddling with permalinks, etc.. In such cases flushing the rewrite rules by following the above steps is required.

    Hey,

    I tried all the methods like flushing the Sitemap cache and excluding the sitemap in Caching plugin.

    My problem is that after I purge all the URL then my sitemap works and shows when I visit it but after some time the same URL responds 404 page not found.

    If I again purge it then the sitemap gets load and then again after some time it responds 404 error.

    Please share the solution fast.

    Hello,

    Could you please update the sensitive data as requested so we can dig deeper into this.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    After checking it, it seems the sitemaps were being cached, even when you have the plugin set to don’t cache them.

    I think it was because Litespeed plugin doesn’t support the format you had for the caching exceptions, so I set all the sitemaps URLs one by one to don’t be cached and it seems to be working now. Could you check it?

    Looking forward to help you.

    At the starting attempt I too excluded the sitemap from cache by their urls only but it did not worked. After sometimes it again popped up with 404 error.

    I will share you the result soon.

    Hey RankMath team,

    The issue did not solve. Still getting error 404 when I visit the sitemap.

    After purging again, the sitemap was available for some time but after that it responded with error 404.

    Please provide any solution fast

    Hi,

    Right now – it is working fine.

    Next time this issue occurs – please ping us and do not make any changes so we can see the issue as well.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 15 total)

The ticket ‘Sitemap Created But Shows Error 403 in Search Console’ is closed to new replies.