Sitemap Couldn't fetch in Search Console

  • When I try to add sitemap to Google Search Console, it showed “Couldn’t Fetch”
    I have tried both /sitemap_index.xml and page-sitemap.xml, but same result
    When I clicked to see the details, it actually shows “Sitemap could not be read”
    Can you please assist?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same problem for 5 websites at the moment

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    The couldn’t fetch error is a recurrent issue with GSC. No one has any idea why it comes and why it goes away on its own. Please give it a few days. The error should vanish. Let us know if it doesn’t.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Thanks for the update!

    Just to update, it turn to be “Success” now when I go to google webmaster and check again. So surprising!

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/?rate=5#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

The ticket ‘Sitemap Couldn't fetch in Search Console’ is closed to new replies.