Since I have changed my theme, my search console doesn’t seem to be connected

  • Hi There,

    On the 6th of June, I changed my theme and ever since, RankMath doesn’t seem to be connected with sitemaps/ WordPress.

    My dashboard used to show around 819k keywords for Search Console Rankmath widget on my dashboard. It seemed stuck and so I went through the setup wizard again… Now it’s only showing 139k keywords?

    I’m not sure if my sitemaps etc have loaded properly and are connecting?

    Please could you help? How do I know if it’s all working as it should? Something seems off.

    Thank you. Sophie

Viewing 15 replies - 1 through 15 (of 22 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you let us know which theme you are currently using.

    You can check if your sitemaps are appearing correctly on GSC without any issues. Then head to GooGLE and check if your pages are getting indexed on SERPs.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hi There,

    I switched from using Avada to using the Flatsome Theme.

    It seems like some of my redirects aren’t carrying over? and my Canonical URLs are causing some issues according to Content King. I’m not sure…!

    I’ve checked my GSC connection on Rankmath and GSC and all seems fine. But the keywords have drastically changed since I installed Flatsome.

    I would appreciate any help please 🙂

    Thank you
    Sophie

    Hi Sophie,

    Can you please try removing the cache and see if that helps?
    https://i.rankmath.com/Zmvjsg

    /wp-admin/admin.php?page=rank-math-options-general#setting-panel-search-console

    Sometimes Google can get wonky with their API.

    Please let us know if that helps. Thank you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi There,

    thank you for this. This seems to have solved my issue with the keywords.

    I have just checked on Google Search Console and I seem to have a coverage issue on my indexed site maps.

    I have one that is ‘submitted and indexed’ and then one that is ‘Indexed, not submitted in sitemap’.

    None of my recent posts since changing my theme are appearing in the ‘submitted and indexed’ coverage section. All of my new posts since 22nd June are appearing in the ‘indexed, not submitted in sitemap’ section.

    I have submitted a new sitemap to Google several times and there is no change.

    Now, when I look at my RankMath sitemaps. The blog posts are appearing in the post site map.

    But, it doesn’t seem like Google is reading those new sitemaps? Is there any way to fix this?

    I don’t know if it’s an issue with my robots.txt file?

    Thank you Sophie
    Thanks Sophie

    Hi There,

    I’ve just checked my site maps and it seems like my last two posts are not on showing on there?

    Do you know how to ensure my sitemaps are being updated?

    These two posts were made with Gutenberg. I just switched editors.

    Thank you
    Sophie

    Hello,

    Are you using a caching plugin? If yes, make sure to exclude these URLs from caching:

    /(.*)sitemap(.*).xml
    /(.*)sitemap.xsl

    After that, if you want, resave the permalinks and the issue should be solved. If not, just let us know and we will help you.

    Looking forward to help you.

    Hi,

    Thank you for your reply.

    I’m using WP Rocket and I have put those URLs into my advanced rules section in the ‘Specify URLs of pages or posts that should never be cached (one per line)’

    Then, I cleared all the cache options. I went to my Permalinks and I pressed save….

    and the Sitemap has still not updated? From previous tickets on the forum this is meant to be instant, right?

    Please could you help?

    Thanks
    Sophie

    Hello,

    Yes, saving the permalinks force the sitemaps to be recreated and since you are not caching them anymore, it should show instantly.

    In that case, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello Sophie,

    Thank you for the details update.

    Unfortunately you seem to have removed your site URL. Please add the URL to your wp-admin so we can investigate this further.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi There,

    I don’t understand what you mean?

    My site URL is https://thirdeyetraveller.com?

    Hello,

    Now I was able to log in but it seems your sitemaps have already been updated (maybe it was not instantly updating since there are several posts and it takes a while to generate them). Could you check if everything is fine now?

    Looking forward to help you.

    Hi there,

    Thank you.

    My latest post has not updated onto my site maps.

    The post is https://thirdeyetraveller.com/jordan-pass-review-is-it-worth-it/

    If you CTRL+F on any of the sitemaps here, it doesn’t appear.

    Plus, if I look at GSC and go to my ‘sitemap and indexed’ coverage the latest two posts I wrote are not being picked up by GSC in the ‘sitemap and indexed’ coverage. They are only being picked up in ‘indexed not from sitemap’?

    The only difference between these latest posts and my other posts are that I built them with Gutenberg and not with the classic editor. Would this make a difference?

    I’m really confused and my Average Position on GSC is going up each day…as if my sitemaps aren’t being read properly?

    Also, I’ve updated a few posts today But all of the posts in my sitemap are still showing 30th of June and not 1st July.

    Surely, It should update with todays date?

    Thank you Sophie

Viewing 15 replies - 1 through 15 (of 22 total)

You must be logged in to reply to this ticket.