SEO tab not working for all pages

  • Hi, I am frustrated!
    I switched to RankMath just for the elementor functionality (and more!)
    But the SEO tab does not seem to work on most pages.
    I have tried disabling plugins and that didn’t help.
    I tried Chrome and Firefox, Same results.
    Please help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Milad,
    i have the same problem. Is there anyone else having this problem?

    regards
    ingo

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    It looks like this error is stemming from the Animentor – Lottie & Bodymovin widget for Elementor plugin that is causing the following error on the page which is affecting the execution of JS:

    frontend.js?ver=1.0.0:144 Uncaught ReferenceError: elementorFrontend is not defined
        at HTMLDocument.<anonymous> (frontend.js?ver=1.0.0:144)
        at i (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,shortcode,utils,wp-util,wp-backbo&load[chunk_1]=ne,media-models,moxiejs,plupload,wp-plupload,jquery-ui-sortable&ver=5.4:4)
        at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,shortcode,utils,wp-util,wp-backbo&load[chunk_1]=ne,media-models,moxiejs,plupload,wp-plupload,jquery-ui-sortable&ver=5.4:4)
        at Function.ready (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,shortcode,utils,wp-util,wp-backbo&load[chunk_1]=ne,media-models,moxiejs,plupload,wp-plupload,jquery-ui-sortable&ver=5.4:4)
        at HTMLDocument.J (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,shortcode,utils,wp-util,wp-backbo&load[chunk_1]=ne,media-models,moxiejs,plupload,wp-plupload,jquery-ui-sortable&ver=5.4:4)

    I can suggest that you reach out to the author of this plugin so that they can help to fix this.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hi Michael,

    for me it is the plugin “Ultimate Addons for Elementor” from Brainstorm Force.

    I hope this can help you Milad.

    regards
    ingo

    Hi Ingo,

    I am glad that you were able to uncover the culprit on your site.

    Please reach out to the developer about this and let them know that we are happy to work with their team to fix this.

    Thank you.

    Thank you for the quick response.
    That was it. It’s working! Back to business 🙂

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)

The ticket ‘SEO tab not working for all pages’ is closed to new replies.