Seo Analysis Issue

  • hey guys i have a problem with the plugin i have in my pages (the keyword is at the start of the content, also the keyword in headings h2 to h6, image with alt tags etc. ) but the plugin shows me error messages and asks me to fix them even though everything is configured correctly.
    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • I have a similar problem too. It noticed it this morning after recently updating my wordpress to version 5.5 or whatever the latest version is called. I have my focus keyword at the the beginning, in the H2 and H3 headings and in my content as well as in the alt text in my images but it says:

    Use Focus Keyword at the beginning of your content. The first 10% of the content should contain the Focus Keyword preferably at the beginning.
    Use Focus Keyword in the content.
    Use Focus Keyword in subheading(s) like H2, H3, H4, etc.. It is recommended to add the focus keyword as part of one or more subheadings in the content.
    Add an image with your Focus Keyword as alt text. It is recommended to add the focus keyword in the alt attribute of one or more images.
    Keyword Density is 0. Aim for around 1% Keyword Density

    I equally have sufficient internal and external links, both dofollow and nofollow but it says:

    Link out to external resources. It helps visitors read more about a topic and prevents pogosticking.
    Add DoFollow links pointing to external resources. PageRank Sculpting no longer works. Your posts should have a mix of nofollow and DoFollow links.
    Add internal links in your content.

    More so,I have good number of images and very short paragraphs, but it says:

    Add short and concise paragraphs for better readability and UX.
    Your content contains images and/or video(s)
    ” but my content has 4 images which normally would turn the tick into green but still stays red.

    Also just to add, all these started today after updating my wordpress to the latest version, cus yesterday and the past days, i have been using the SEO analysis and i got most of my pages and post scoring 90+. Today it doesn’t even cross 53. I have refreshed the pages and even went as far as deleting and rewriting the content to no avail.

    I decided to just stop and inquire whats happening. Looking to have this fixed soon.

    Hello,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    Assuming you are using the latest version of all the plugins and the themes (please update if not yet), it would seem like a conflict with one of the plugins or the theme you are using.

    To determine that, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Please let us know if you find the culprit else we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hey;
    Thank you for your reply, it was a conflict with a page builder plugin “SiteOrigin Page Builder”, i disabled it and now rank math works correctly
    Thank you for your feedback

    Hello,

    Those are good news! Then, do you have any other questions? Or do you want us to close this thread? In any case, we will be here if you have any other questions or issues in the future.

    Looking forward to help you.

    Hey Rankmath, thanks very much for your reply and solution. I followed the instructions and it turned the problem too for me was the conflict with “SiteOrigin Page Builder”.
    I have it disabled and everything now works great. Thanks very much for the help support, its really very much appreciated.

    Thank you, for me everything is great at the moment, thank you guys you did a great work.
    Cheers

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

The ticket ‘Seo Analysis Issue’ is closed to new replies.