Search Console not showing my website

  • Hello, I’ve followed your instructions on setting up the search console, verified the account etc, but when I refresh the sites my others are showing up, but not the new one. I have verified connection between my site and google using the analysts to track traffic. I have also tried to deauthorise and re-authorise, but it still doesn’t show my site, please tell me what I’m doing wrong

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    This suggests that your site verification process was not successful. You can fix this by verifying your property using a different method such as the DNS record method.
    Please take a look at this page for more info on this: https://support.google.com/webmasters/answer/9008080?hl=en

    I hope this info helps. Thank you.

    ​​​​​​​

    I also have that problem.
    The new site is verified inside Search Console.
    But refreshing the list won’t help, and the new site doesn’t appear.
    I tried deauthorising again and again, waited ome days but still the list won’t show the new site.

    Solved!
    I entered Search console (not through the plugin)
    and added the new site manually.
    It seemeed as if I need to verify again, but after a few seconds the new site appeared.
    Now inside Rank Math I didn’t need to refresh and it started to fetch data

    Hi there,

    Thanks for the follow up.

    I am glad that this is now resolved 🙂

    Feel free to contact us should any other issues come up.

Viewing 4 replies - 1 through 4 (of 4 total)

The ticket ‘Search Console not showing my website’ is closed to new replies.