Referenced AMP URL is not an AMP

  • Resolved Zorain

    Hey,

    After shifting to Rank Math from Yoast, although I am pretty happy with Rank Math but since past few days my traffic dropped my 80% margin and when I opened my search console I found out that there were lots of AMP Errors.

    View post on imgur.com

    As (in the screenshot above) I am getting tons of “Referenced AMP URL is not an AMP” errors, after digging out I found out:

    View post on imgur.com

    All of my amp posts were being categorized as “uncategorized” and whenever I open any URL instead of redirecting to its specified category I was being redirected to “uncategorized” posts.

    View post on imgur.com

    Even tho I only have 7 posts in my “uncategorized” category but around 133 posts are being categorized as “uncategorized”.

    I am baffled as to what is happening, I can’t find a possible fix nor i can understand what happened.

    Please do help me sort out this issue, I would like to continue using Rank Math since it optimizes my Structured Data for News Article whereas Yoast couldn’t.

    • This topic was modified 1 month ago by  Zorain.
    • This topic was modified 1 month ago by  Zorain.
    • This topic was modified 1 month ago by  Zorain.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    bump

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been
    caused due to that.

    Kindly allow me to consult the dev team on this and then I’ll get back to you.

    Looking forward to helping you.

    Thank you.

    ​​​​​​​

    Hey Micheal,

    Thank you for looking into it, I am awaiting your support.

    Best

    Hey,

    I would love to know whether this issue is on my side or yours, my traffic is going down day by day. Old URLs are being categorized as “uncategorized” aforementioned. It’s working fine for newer URLs/Posts. But older ones are dropping out of Google.

    It’s been a week since I opened this ticket, please update me with the status and do let me know if you need any necessary details.

    • This reply was modified 3 weeks, 3 days ago by  Zorain.

    Hello,

    Thanks for getting in touch with us today and sorry for the huge delay.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi there,

    Thanks for the response.

    The category is actually not deselected and my recommendation will be a bit tedious since you will need to fix this by resaving the affected posts and checking the “Primary term” feature on the category section of the post.
    The primary term setting appears to have gotten deselected during the import and we will be doing more tests on this to establish whether there is a pattern.

    I hope this info helps. Thank you.

    Thank you for getting back to me.

    Your solution is appreciated, tho it may take some time to do it manually.

    After doing so, how can I make the errors disappear from search console? Should I just click on validate button in search console after fixing the primary categories?

    Thank you.

    Hello,

    Thank you for contacting Rank Math today.

    After this is complete, clicking on validate fix should be able to fix the problem.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 10 replies - 1 through 10 (of 10 total)

The ticket ‘Referenced AMP URL is not an AMP’ is closed to new replies.