Redirects not working

#486273
  • I’ve set up my first set of redirections for the site. For some reason they are having no effect at all. I’m still getting 404 messages on all the old URLs.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    Thank you for contacting Rank Math and bringing your concern to our attention. I’m sorry for any inconvenience this issue may have caused you.

    Could you please share the URL you’re trying to redirect? Also, please take a screenshot of the redirect setup you have made.

    You can upload the screenshots using this tool and share the links in the sensitive data section

    Sensitive Data Section

    It is completely secure, and only our support staff has access to that section.

    Meanwhile, here’s a guide on how to use Rank Math redirections:
    https://rankmath.com/kb/setting-up-redirections/

    Looking forward to helping you.

    Thank you.

    I think I may have resolved the issue. I switched the URL to Exact match whereas before I had been using Contains or Starting With. It seems to work that way. Should I just avoid the ‘Starts With’ setting? Thank you

    Hello,

    The purpose of the “Start With” condition type is to check if there are matching redirection rules that start with certain words or characters.

    For example,

    If you set your Redirection rule to “test” and you have a URL https://yourdomain.com/testme, then this should match and the redirection will trigger.

    If this doesn’t apply to you, then you can use other condition types.

    Hope that helps.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this ticket.