Redirection isn’t working

  • I reviewed the instructions for creating these and it looks correct but when I hit the URL it redirects me to the home page of my site instead of to the target URL. Please advise.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you try adding the full URL in the source URL field or switching it to “contains” instead of “exact” and letting us know if that fixes your issue?

    If not, we will continue helping you until we solve it.

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Ok, I tried that but I’m getting the same behavior, redirecting to home page.

    Hello,

    Then, we might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I have just checked it and it seems if the redirection has a “/” inside (like it was your case), the URL to redirect is not being redirected, but if you remove the ‘/’, the redirection works perfectly.

    I will notify the devs so they can check it as soon as possible.

    Looking forward to help you.

    Even if I remove the sub-directory, it doesn’t work for me, still redirects to the home page. Are hyphens also a problem?

    Hello,

    No, it should work perfectly fine, I tried it in my own local installation and it worked fine (as you can see in this screencast).

    It could be some conflict on your website, so I recommend you check if there is some plugin conflicting with it; meanwhile, I am going to ask the rest of the Rank Math team if they know which could be the cause.

    Looking forward to help you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)

The ticket ‘Redirection isn’t working’ is closed to new replies.