Rankmath not working with EDD properly

  • Hello,

    I have used rankmath in my wordpress + Easy Digital Downloads plugin, because it says it’s compatible with EDD but it’s not totally compatible and i got lot of problems.

    1 – For some reason it doesn’t rank most of my images even if i have the Auto alt or even if i do it manually.
    2 – It redirect most of my images to other links for example (I have picture A with info & link ===> when i find it on google image search i find that the image have info from other picture & the link take to other picture and this is weird, i tried even to submit some images manually still the same only when i activate rankmath plugin).
    3 – the same thing happen with google search, i find the link but with different info.

    So can you please help with this

    • This topic was modified 1 week, 3 days ago by  pingo gaz.
Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello,

    Thank you for getting in touch with us and sorry for any inconvenience caused.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hi Michael,

    Thank you for your reply, i have included my wp logins, even if i have already you before when i posted a question about the sitemap, hopefully you can help me with that.

    Hello,

    Thanks for the access.

    1). I have inspected several images on your store and I can see that the automatic alt tags have been added as shown below:
    ALT tags

    2). Most of the images on Google are older images that might have been indexed before you installed Rank Math because your posts do not appear to be indexing on the search console:
    Sitemap

    Please check from the search console if the sitemap URLs have been fetched.

    We are looking forward to helping you. Thank you.

    Thank you for checking that, i just checked on my end and found that the sitemap.xml is been confirmed by google but most of the links are not indexed via the sitemap, because i had problems while submitting the sitemap time ago when i posted on here.

    Now i see that even if the sitemap is in there google still didn’t use the sitemap to fetch urls so i got a lot of problems with images and links the whole seo is ruined 🙁

    I don’t really know how to force google bot to read only from the sitemap, i’ve been having that issue for 2 months now.

    Hi there,

    Thanks for getting back to us.

    Your Litespeed server is caching the sitemap file, here is the response that I get a curl request:
    Curl Response

    Please get in touch with your host so that they can help in bypassing the cache rules on this file.

    Thank you.

    I have a vps server that i installed cpanel on it myself, when i contacted VULTUR VPS they told me they are just able to check this that are related to the server configuration.

    So i checked some tutorial on litespeed blog about that problem and they said to disable w3 total cache plugin or any caching plugin so i did but still don’t know if thats works fine or no.

    Can you please tell me if something changed ?

    Hello,

    Thanks for getting back to us.

    I am afraid that there is no change, please ensure that you have purged the cache before deactivating your caching plugin. You can test the changes on the sitemap file here https://onlinecurl.com/

    I hope this info helps. Thank you.

    Hello,

    How do i know that there is changes ? Everytime i test on that link i find the same results ? but don’t know which line to see if there’s changes ?

    Hello, any reply please for my last reply on this post ?

    I have purged all the cache before testing and tested again i still see the same result in red ?

    Hello,

    Apologies for the delay.

    I can see that you have the Google XML sitemaps plugin installed. Can you confirm that the issue is still replicated when the Rank Math sitemap is disabled and you use the sitemap from this plugin?

    Let me know how this goes. Thank you.

    I don’t really remember but i have tested like RankMath & 2 other plugins for sitemap but in that time i’ve had issue or a bug, i couldn’t submit any of the sitemaps, but after 2 weeks “RankMath Sitemap” got submited to google and now it’s been 2 months and google still not indexing any link via the sitemap ! it only fetch links randomly !!! sometimes i find them in search sometimes it disappear.

    I don’t really know where is the problem exactly.

    Hi Pingo,

    Thanks for getting back to us.

    Please delete the current sitemap and resubmit a new one and then wait for a couple of days and check whether this will have resolved the issue.

    Let us know how this goes. Thank you.

    Okay i will do and check that and will let you know the updates.

    Thank you for your help

    Hello,

    Great! We will be looking forward to an update from your end.

    Thank you.

Viewing 15 replies - 1 through 15 (of 16 total)

You must be logged in to reply to this ticket.