RankMath makes my product pages open very slowly

  • Hi there,

    I have an interesting issue. When RM is activated, my product pages in WC take minutes to fully load. I created a screen video for you to see the difference between RM activated and deactivated and the time it tales to open 2 product pages (one in Dutch, one in English), see https://www.dropbox.com/s/5j5lh3l8oy96j8y/Rec%202020-10-15%2013%3B26%3B20.mp4?dl=0

    Would you have any idea how come? And what I can do to resolve this? I have tried activating and deactivating all plugins and the culprit is RM I am afraid.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Can you please let us know which tool you are using to test the speed on both stages?

    We have activated the plugin and tested your products and those are still loading slow when the plugin is deactivated.

    You can also use the below tool to check the speed on each case.
    https://tools.pingdom.com/

    Let us know if we have missed anything.

    Thank you.​​

    Hi Jitendraa,

    I don’t use a tool, I just check the pages as I open them as a user. You can see in the video link (DropBox) I sent you the significant difference.

    Hi Jitendraa,

    I have done a speed test to check the difference with and without RM activate, and these are the results.
    RM actived:https://tools.pingdom.com/#5d4c13f5e2800000 (screenshot: http://prntscr.com/v0dj9c)
    RM deactivated:https://tools.pingdom.com/#5d4c136841800000 (screenshot: http://prntscr.com/v0diy0)

    I agree that even without RM activated the page loads slow, however as you can see from the test results, when RM is activated some strange error time wise appears on Pingdom. I have done the test several times to make sure it wasn’t a glitch but these are the results each time.

    I hope you can help me.

    Thanks!

    Hello

    Sorry for any inconvenience that might have been caused due to that.

    Assuming you are using the latest version of all the plugins, themes, and WordPress (please update if not yet), it would seem like a conflict with one of the plugins or the theme you are using.

    To determine that, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Looking forward to helping you.

    Great! Let me do that. Thanks

    Hello,

    Were you able to resolve this issue? If you did, please let us know.

    If you have any further question(s), please let us know. Thank you.

    Hi there, we are still working on it. I will update this. We found a conflict between Avada child theme and RankMath and now need to see which one if the culprit. I will update this ticket once done.

    Hi, we fixed the Health Check issue that were suggested for our child theme but the site still loads forever with RM active. We have therefore decided to save ourselves time as this had cost us hours already, and have installed Yoast SEO which doesn’t have this issue. I am sure you’re not happy to hear that but we need make efficient use of our time.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this ticket.