Product sitemap not working

  • Hi,

    Pasted the link for the product sitemap, it gets an error 500.
    The main sitemap index and category sitemaps are working fine.

    The error through the xml checker is
    Incorrect http header content-type: “text/html; charset=UTF-8” (expected: “application/xml”)

    • This topic was modified 1 month, 1 week ago by  webshop. Reason: Added xml checker
Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    This error suggests that there is a conflict with one of your installed plugins that is breaking the generation of the sitemap file. Please perform the steps outlined on the following page to check for conflicts: https://rankmath.com/kb/check-plugin-conflicts/

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Sorry for the delay, tried with health check and only woocommerce enabled. still not working. both category and page sitemaps working, product not.

    Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)

The ticket ‘Product sitemap not working’ is closed to new replies.