Product pages not indexing

Viewing 3 replies - 1 through 3 (of 3 total)
  • Having the same issue here

    My domain Ahref authority is 50+. When I submit the article links in the rank math index tool, article pages are getting crawled immediately but not getting indexed. I submitted the article and got success for the same. In the Search Console, it shows Indexed, but when I run “Test Live” it shows not indexed. I searched on Google as well but could not find my page.

    Hello,

    Thank you for getting in touch and I am extremely sorry about the trouble this might have caused.

    There are a few things you must check for in order to see why the posts aren’t getting indexed.

    1. Make sure the post is not selected as ‘noindex’ in WP > Posts > Your Post > Advanced Tab in Rank Math.
    Screenshot:

    Individual Post Advanced Tab

    2. Ensure that the noindex is not selected for Global or Posts meta:

    Noindex Settings

    3. Check the sitemap settings and check if the posts are setup to be included in the sitemaps:

    Post Settings

    Please note that it is completely upto Google if they want to index or not index your website. So, if you haven’t willingly or accidentally made your posts noindex and Google still isn’t indexing your page – it means that either Google doesn’t want to index or hasn’t crawled your page yet because it hasn’t allocated that much crawl budget to your website.

    Please check this website for more details.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this ticket.