problem with social media links

  • I am opening a ticket as suggested on facebook.

    I just noticed, for some reason it is not using my TWITTER content in the social settings.
    If I a tweet a blog post, it is just using the default Title + link content.

    Here is an example. see this blog post: https://michaels.me.uk/google-discriminates-against-small-businesses/

    If you tweet it, then it will use “Google discriminates against small businesses https://michaels.me.uk/google-discriminates-against-small-businesses/ via Russ Michaels

    This is not what is set in Rankmath.

    I am NOT using DIVI builder in posts, they are just regular posts using the WP block editor.
    I have also tried disabling the DIVI theme and switching to seventeen theme.
    Which means there are no shortcodes in use as Alex says, since these are generated by the divi builder, and which I am not using on posts, and with the theme disabled, all shortcodes would stop working anyway.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    I have just tested your page on the Twitter card validator and Rank Math is adding the twitter cards correctly on the page as you can see below:
    IMG

    Is this the data that you have added on the backend?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    here is a screenshot of my rankmath social settings for this post.
    https://nimb.ws/UQsJCZ

    Now go to the post

    Google discriminates against small businesses

    and click on the “tweet” button and see what you get.
    As you can see it is not the same.

    Hi there,

    Thanks for the follow up.

    This issue is not related to Rank Math since our plugin is adding the twitter card successfully on the page. I have gone ahead and created a tweet using the post URL and as you can see below the rights data is displayed:
    IMG

    I would suggest that you reach out to your theme author or the author of the plugin that is adding the share buttons so that they can advise on this issue.

    I hope this info helps. Thank you.

    1. You say it is correct but it clearly does not match the description I set in rank math, as per the screenshot I have sent you, please look at the screenshot I sent you more closely.

    As stated in my original post

    QUOTE “I have also tried disabling the DIVI theme and switching to seventeen theme.”

    So reaching out to the theme author would be pointless, since the first thing they will say is “try with the default theme and see if the issue still occurs”. Which I have already done as stated above and the issue still occurs, so is obviously not related to the theme, which is exactly what they will tell me.

    I have also tried multiple different social media plugins with the exact same result, so the social media plugin is not the cause either.

    Hello,

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    Temporary Login Without Password

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    WP Security Audit Log

    We really look forward to helping you.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

The ticket ‘problem with social media links’ is closed to new replies.