Post images are not redirecting to post

#155664
  • Hello guys,

    I don’t understand why featured images of our website indexed on google is not redirecting to post itself but redirecting to home or some other post.

    Could you please help?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting Rank Math and bringing your concern to our attention. I’m sorry for the delay and for any inconvenience this issue may have caused you.

    I’ve checked the images, and it seems that they are being redirected to their respective URLs. However, there is one image that redirects to your homepage. Please see the screencast in the designated Sensitive Data section.

    Could you please confirm if that is not the image you have set for your homepage? Also, which of these options are you using for your homepage displays in Settings > Reading?
    Homepage

    I hope that helps. Thank you, and looking forward to your update.

    Hi Reinelle,

    I think you didn’t read properly or didn’t understand it.

    I mentioned
    “featured images of my website indexed on google is not redirecting to post itself but redirecting to **********homepage or some other post.***************

    I have attached another screenshot, kindly check again.

    Hello,

    Thank you for the follow up.

    You have set your homepage to show your latest posts and also have your category pages indexed. In this case, it seems Google is reading a number of your images not from the their original posts but from where they are archived at which might be your homepage or your category pages or as it seems, a post within the category.

    Would you please check if you have enabled the option to redirect attachments in Rank math > General Settings > Links. If you haven’t, please enable it and give it a few days for your images to be crawled again and let us know if this helps.

    Looking forward to helping you.

    Yes it is enabled.

    I have shared my wp credentials in “Sensitive Data” kindly check.

    Hello team,

    Could you please help me fix the issue?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this ticket.