Pages marked as noindex appearing in XML sitemap

  • I marked several pages as noindex, after noticing them in my XML sitemap. After marking these as noindex, clearing my site cache, I still see the noindex pages listed in the XML sitemap.

    Is this expected behavior?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    No this is not expected behavior. Could you please do the following:

    1. Head over to WordPress Dashboard > Settings > Permalinks

    Hit the save button once.

    2. Go to WordPress Dashboard > Rank Math > Sitemap Settings

    Hit the save button once.

    That should fix the issue.

    If it doesn’t, please do let us know so we can look at this further.

    Thanks for the helpful response. I’ve done these things, and purged the cache on WPengine and it doesn’t seem to have solved the problem.

    Hi Garrett,

    Sorry about that.

    Can you please share the URL in question that you marked as noindex but it still appears in the sitemap?
    Of course, we are assuming you already tried clearing the cache and cleared CloudFlare cache as well if you are using it.

    We would love to take a closer look.

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)

The ticket ‘Pages marked as noindex appearing in XML sitemap’ is closed to new replies.