Page Not Found > No track on GA

#279170
  • Resolved Rohan
    free

    Hi

    I am using Buddyboss theme and plugin.
    Recently switched SEOPress to Rankmath and encountering a couple of issues.

    those pages (Activity / Community(group) / Members / etc ) developed by Buddyboss team show the page title as Page Not Found.

    I have gone through many other articles and managed to add the title that I want via code snippet (function.php)..

    I can accept that.

    but after I enabled ‘404 monitor’, the issue is when a user visit those pages, GA (Google Analytics) is not taking the count in.

    I tested myself using incognito mode as a visitor to visit the those mentioned pages. GA is not reflecting for some reason.

    so I had to turn off ‘404 monitor’.
    Bottom line is to understand what causes ‘page not found’ (404 issue) with buddyboss plugins and theme.

    Any idea?

Viewing 15 replies - 1 through 15 (of 24 total)
  • Hello,

    Thank you for contacting us and sorry for any inconvenience that might have been caused due to that.

    We checked your website and it seems that is not even able to detect a proper 404 page because each time we access a page that doesn’t exist we get redirected to a login page with a 302 redirect status code.
    ​​​​​​​
    We also checked the source code of your website and it seems that you are implementing multiple GA tracking codes that could be conflicting with each other.

    We recommend that you only use one method to implement this code on your website.

    You can also use this plugin to check what tags are installed and working on your website: https://chrome.google.com/webstore/detail/tag-assistant-legacy-by-g/kejbdjndbnbjgmefkgdddjlbokphdefk?hl=en

    Hope this helps clarify your doubts.

    Don’t hesitate to get in touch if you have any other questions.

    OK i managed to remove the duplicate the GA tag. Now I have 1 > so i can see that GA is detecting the traffic for some reason.

    Maybe I should not move away from the oringial issue which is ‘Page Not Found’ title. I overcome by adding the title with function.php

    but I foresee other issues with this method.
    activity/?activity_search=%23xxxx > will still give ‘Page not found’..

    I would like to seek your help where and what caused ‘Page Not Found’ on the title?
    Are you able to tell?

    Pleae help.

    Thank you

    Hello,

    We might need to take a closer look at your admin dashboard and see why you are seeing that incorrect title in BuddyPress pages. Please edit the first post on this ticket and include your WordPress & FTP logins in the designated Sensitive Data section.

    Please do take a complete backup of your website before sharing the information with us.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Pleae take a look at the screenshot in the sensitive data..
    I have not submitted any ‘noindex’ meta tag but Google Search Console said there is… i have no idea where it came from and how to remove them…
    please help…

    Hello,

    I checked the page source of the URL, it is set to noindex:
    robots

    I logged in to your website to check the settings, but the login that you have provided is very limited. Please provide admin-level access so we can check further.

    Alternatively, you can go to this activity page > SEO settings > Advanced Tab > Check index checkbox
    https://rankmath.com/kb/advanced-tab/

    Hope this helps. Looking forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    I updated your role. Please help check further.

    I have even modified the robot meta for that page. I shared the screesnshot in the senstive info update.

    Hello,

    Something must be overriding this specific page’s robots meta. It could be a plugin or your current theme.

    I tried enabling the troubleshooting mode but it seems I can’t enable the plugins while in troubleshooting mode.

    Could you please follow this troubleshooting guide and see if you can locate what’s causing this issue? https://rankmath.com/kb/check-plugin-conflicts/

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    If you prefer, you can create a staging website for this instead, replicate the issue there and share the WP login with us. This should allow us to further investigate the issue without worrying about breaking your live site.

    Looking forward to helping you with this one.

    I have enabled that plugin and turned off cloudfront which caused the error when installing/enabling a new plugin.

    You can take it from here.

    Regarding the staging site, i have created it before contacing you but the funny part is.. the staging site has no such issue althu i copied exact (export and import), so I am really clueless. need your expertise..

    would it be the reason I switched from SEOpress? I am not sure…

    Thank you

    I have found that the issue is happening on staging env as well.

    so I shared the access. Please feel free to troubleshoot there.

    Hello,

    This issue seems to be caused by some incompatibility with the Cartflows plugin and Rank Math.

    When we disabled that plugin the page started outputting the correct meta data.

    We are investigating this from our end but we also recommend getting in touch with the developers of that plugin to see if they have experienced this and have a fix from their side already for this.

    Don’t hesitate to get in touch if you have any other questions.

    Thank you for the update. I am glad that you found the conflict.

    I happened to check their facebook group
    https://www.facebook.com/groups/cartflows/posts/517445252128368

    this issue was reported in 2019… Just wondering if the issue was fixed back then?

    I tried to install back the cartflow (not enabled) but robot shows ‘index’ correctly tho..
    with this, I am not sure if cartflows is the one unless you put some codes?

    Hello,

    The correct robots meta is showing in the staging site even with Cartflows installed but in the live site, the issue persists.

    I wasn’t able to see the Facebook post you shared as I am still waiting for the admins of that group to accept my request to join.

    We would like to further debug this but the live site’s temporary login isn’t working anymore.

    Could you please renew it since the issue is only happening there?

    Looking forward to helping you.

    OK the access has been reactivated on live site.
    I tried to turn off cartflows and cleaned up the cache but it seems still showing noindex..

    Anyway you can test it yourself. since it’s a live site, cartflow needs to be turned on back once you are done with the testing.

    Let me know your findings. I appreciate your help here! if I get the pro version, will i be able to get more intensive assist from your team?

    I can’t wait to get this fixed for good which has impacted my SEO for long time..

    Thank you

    Hello,

    Since we did not hear back from you for 15 days, we are assuming that you found the solution. We are closing this support ticket.

    If you still need assistance or any other help, please feel free to open a new support ticket, and we will be more than happy to assist.

    Thank you.

Viewing 15 replies - 1 through 15 (of 24 total)

The ticket ‘Page Not Found > No track on GA’ is closed to new replies.