og:title not updating or pulling from content

  • I duplicated a site (ExpediteFM) to a new one (ExpediteIT) and updated all content accordingly, however although everything (I have tripled checked) it updated, the og:title and description refuses to update in RM: https://grab.mogmachine.com/WnuJvqp4

    – Homepage is ‘latest posts’ just uses index.php in template for custom page: https://grab.mogmachine.com/6quelEoE
    – Social setting in main settings are empty
    – I cleared all transients in the db
    – there are no conflicting plugins : https://grab.mogmachine.com/P8ubo6Kg
    – main settings options updated: https://grab.mogmachine.com/ApukbxoX

    There is literally no where else that data could or should be set yet the old FM data continues to populate og:title and :description and same for twitter even though you can clearly see this contradicts the <title> and base meta description.

    What have I missed?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    We might need to take a closer look at the settings. Please edit the first post on this ticket and include your WP logins in the designated Sensitive Data section.
    Sensitive Data Section

    It is completely secure and only our support staff has access to that section. If you want, you can use the below plugin to generate a temporary login URL to your website and share that with us instead:

    https://wordpress.org/plugins/temporary-login-without-password/

    You can use the above plugin in conjunction with the WP Security Audit Log to monitor what changes our staff might make on your website (if any):

    https://wordpress.org/plugins/wp-security-audit-log/

    We really look forward to helping you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Thank you for getting in touch with us.

    I changed your opengraph title to be same as your homepage title in Rank math > Titles & Meta > Home page. Some options are only available when you enable the Advanced Mode in Rank Math. I switched your site to the Advanced Mode, which can be done from the top-right corner at WordPress Dashboard > Rank Math > Dashboard

    Here is a screenshot for reference:https://i.rankmath.com/oMQ5Vj

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Thanks ..i didn’t realise that advanced mode was not on and it was driving me crazy ..lesson learned ..much appreciated.

    Hello,

    We are super happy that this resolved your issue. If you have any other questions in the future, know that we are here to help you.

    If you don’t mind me asking, could you please leave us a review (if you haven’t already) on https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post about your overall experience with Rank Math? We appreciate your time and patience.

    If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

The ticket ‘og:title not updating or pulling from content’ is closed to new replies.