not optimising website automatically, showing errors when it shouldn’t.

#192930
  • Hi Im Steven from Premiumslatesuk.com I switched over from using Yoast to Rank math, however, I’m seeming to be having more issues than ever. When I transferred over it swapped everything over SEO wise but I have to now open every page/ product page for it to register its ranking (SEO details tab)? which is taking forever. Why is it doing this?.

    Its also showing errors such as “The Focus Keyword wasn’t found in the content” yet it’s in the title and the first paragraph, its showing errors when it shouldn’t show errors.

    I wanted to upgrade to the PRO version but I’m hesitant as I’m not having the best luck with Rank Math. It’s supposed to be better and easier to use than Yoast but I’m not finding that’s the case.

    Also I’m using Flatsome theme and UX builder so it doesn’t highlight errors on either the front end or back.

    Can you help? sales@premiumslatesuk.com 07833491218

    It’s critical the sites fully optimized and ranking on the first page of google and I’m struggling to even get setup correctly with Rank math.

    Kind regards

    Steven

Viewing 1 replies (of 1 total)
  • Hello,

    Thank you for contacting Rank Math support, and sorry for the inconvenience caused to you.

    If you are using a firewall, please disable that temporarily and see if the issue goes away.

    You can also check the Browser Console and see if there is any error while you try to save the Rank Math settings like the Focus Keyword:
    https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/

    You can share a screenshot of the console with us if you see any warnings or errors.

    Alternatively, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Do keep only Rank Math and default theme enabled and see if the issue persists.

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Please let us know if you find the conflicting plugin/theme.

    I hope that helps. Thank you, and looking forward to your update.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this ticket.