no seo performance and no keywords

#209710
Viewing 15 replies - 1 through 15 (of 23 total)
  • Hello,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    I have performed the manual data fetching from the Rank Math. I would take approximately 50 minutes. You can also see the timer inside the rank math dashboard. Let see how that goes.

    Looking forward to helping you.

    Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience caused.

    Let’s try deleting old imported data and start the fresh data fetch. Please follow these steps.

    1. Head over to WP Dashboard >> Rank Math >> Tools & Status and click the ‘Rebuild Index’ button https://i.rankmath.com/kecLYK
    2. Head over to WP Dashboard >> Rank Math >> General Settings >> Analytics tab, and click the ‘Delete Data’ button and then click the ‘Update Data Manually’ https://i.rankmath.com/fvcsbF
    3. It will start the new data fetch from Google. You can reload the page to see the notice related to the import process.
    4. Once the process is complete. Please recheck the Analytics page.

    I hope this helps.

    We look forward to helping you.

    Thanks for you reply. I’ve yet done this many times without any result unfortunately but let’s see if this time something will change. I’ll let you know…

    Hello,

    Thank you for the update.

    Sure, let us know how this goes.

    We also wanted to further check the site, but it seems that you’re using 2FA. If the issue still persists, please also disable it so we can check your site again.

    Looking forward to helping you.

    Thank you.

    Hello, the user I’ve sent you is not under 2FA please check since was used by your colleague to reset the fetching.

    In any case I’ve checked now and the situation is exactly as before. Seo performance and keywords are completely empty.

    Hello,

    Thank you for contacting Rank Math, and sorry for any inconvenience caused.

    It seems that the cronjobs are disabled in your installation.
    cron

    In order to fetch the data correctly and consistently, you need to have the cronjobs working and enabled in your installation.

    If you are not sure how to do it, you can get in touch with your web host.

    Hope this helps solve your issue.

    Don’t hesitate to get in touch if you require any further assistance.

    Sure, but I’ve wp CRONTROL that do this job

    https://www.tuttosullapostaelettronica.it/blog/wp-admin/tools.php?page=crontrol_admin_manage_page

    that give me more access and control on the cron. I haven’t had any problem with the cron for other plugins but maybe you’re right…

    maybe there’s to add something here to make RM work…

    Can you tell me if this is the problem and why two cron are working and not the others?

    https://pasteboard.co/K5VMytN.png

    Hello,

    Thanks for getting back.

    To enable the cron system open your wp-config.php file located in the base root of your WordPress directory and look for a PHP Constant named DISABLE_WP_CRON and set its value to false.

    define('DISABLE_WP_CRON', false);

    You should be able to fetch the data after enabling the cron system.

    Hope this helps. Let us know if you need any further assistance.

    Ok let me try

    Ok done that, deleted the data and started the manual update

    https://pasteboard.co/K5Wm51M.png

    I’ll let you know if it will work…

    Hello,

    Thanks for getting back.

    Let us know how that goes.

    We really look forward to hearing from you.

    Checked now and it seems that the fetching is always in progress and it has now been more than 2 and a half hours since the fetching started…

    I don’t think that the cron has something to do in that

    Update
    Fetching is finished but the data is still missing. Everything is as before…

    Can you check please?

    P.S. I’ve the same problem on another site on another server where these data are missing as well.

    Hello,

    Thank you for keeping in touch with us.

    Allow me to escalate this issue to our dev team to further investigate. We should get back to you with a solution or update shortly.

    We appreciate your time and patience on this one.

Viewing 15 replies - 1 through 15 (of 23 total)

You must be logged in to reply to this ticket.