No: ‘noindex’ detected in ‘X-Robots-Tag’ http header

  • Hi rank math Team
    I am really facing problem after transferring from Yoast to Rank math . My site is not appearing on google search by any my keyword after i transferd my site from yoast to rankmath .

    I am getting following issue when i submit my sitemap to google webmaster .

    Crawl
    Time
    Jun 27, 2020, 1:17:59 AM
    Crawled as
    Googlebot smartphone
    Crawl allowed?
    Yes
    Page fetch
    Successful
    Indexing allowed?

    No: ‘noindex’ detected in ‘X-Robots-Tag’ http header
    Indexing
    User-declared canonical
    N/A
    Google-selected canonical

    Only determined after indexing

    Please help me on this . Why my website is not appearing on any keyword search which i used for my site .

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello,

    Thank you for contacting Rank Math and sorry for any inconvenience that might have been caused due to that.

    Could you share the affected URLs in the Sensitive Data section so we can check them?

    Looking forward to helping you. Thank you.

    ​​​​​​​

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I have checked your URL and it appears fine from y end. You seem to have 10 URLs submitted and only page sitemap. Is there something missing from this? Please share a screenshot of the error as it appears from your end.

    Could you also please remove all sitemaps and resubmit only the main sitemap on your GSC.

    Looking forward to helping you. Thank you.

    ​​​​​​

    Hi David
    Thanks for the reply
    Dear the problem which i am facing is that i have 10 pages on my site including home page . Every page has its own keyword . I remember my site use to appear before when i was using yoast plugin with my keywords . Some pages in 15th page of Google some in 12th page of Google some in 10th page of Google .

    But when i shifted from yoast to Rank math my site pages no longer appearing on google search even last page of google .

    Yes i Know When i type my domain seerazatia.com & Site:seerazatia.com . My site Appears.

    But None of my 8 pages appear when i type my keywords ,Below are the keywords of my Pages you can see My pages are not appearing on Google Search Result .

    [keywords removed]

    This happened after I shifted from Yoast to Rank Math .

    Please check and help me what exactly is the issue . As my site is 3 months old .

    Hello,

    I have checked some of your pages and as you said, they are set as no-index.

    There are a few things you must check for in order to see why the posts aren’t getting indexed.

    1. Make sure the post is not selected as ‘noindex’ in WP > Posts > Your Post > Advanced Tab in Rank Math.
    Screenshot:

    Individual Post Advanced Tab

    2. Ensure that the noindex is not selected for Global or Posts meta:

    Noindex Settings

    3. Check the sitemap settings and check if the posts are setup to be included in the sitemaps:

    Post Settings

    Please note that it is completely upto Google if they want to index or not index your website. So, if you haven’t willingly or accidentally made your posts noindex and Google still isn’t indexing your page – it means that either Google doesn’t want to index or hasn’t crawled your page yet because it hasn’t allocated that much crawl budget to your website.

    Please check this website for more details.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Hi Alberto
    Thanks for the reply
    yes i am the one who disabled the POSTS to be Indexed because i don’t have any Blog Posts . I have only Pages and that is the reason i disabled POST as Noindex .
    I want only my Pages to be indexed on Google .

    Now i have changed POST as you said to Index which i have done it .

    I hope google starts indexing my site now

    Thanks

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    Could you check the same steps I send you in my previous messages but instead of in the posts, with the pages?

    Looking forward to help you.

    Hello,

    I have updated the sensitive data as requested. Can you please check further?

    Thank you.

    Hello,

    I removed the keywords on the thread as per your request. The data in the sensitive will be automatically disposed of as soon as you set the thread to resolved.

    Looking forward to helping you. Thank you.

    ​​​​​​

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this ticket.